What's the operating system that runs WD players?

What’s the operating system that runs on WD players? Linux? Android? Or WD’s own creation?

Linux … With WD proprietary code (and encryption) and GPL Code which WD make available for download under GNU General Public License.

Thanks, JoeySmyth.

I ask the question because I have two old WD players - a Live TV and a Streaming model.

Both can see my Windows network and play media from my main PC without hesitation or glitch.

While a brand new Vero 4K box will not.(And believe me, I’ve tried everything :frowning: )

So I wanted to establish if their respective operating systems are very different, or quite similar.

Seems they share more similarities than differences.

I don’t think operating systems have anything to do with why the WD’s work on your network and the Vero 4K box does not. (Vero 4K box is running Debian Linux FYI) … it’s a Network Setting/Config problem, not an OS problem.

It’s probably because the WD TV’s (and your Windows) are still using SMB1 (which is a security issue)

And the Vero 4K has been patched for the Wannacry security issue … and is running SMB2 and/or SMB3

Okay, I hear where you’re coming from - I’ve been asking questions all around the net for the last several months, about the SMB protocol and have yet to find someone who knows the entire story.

(I guess there’s an MS supergeek somewhere who fully understands the process and its history, but they don’t talk to ordinary mortals).

Your comment about SMB1 is the first that’s made sense, so thanks for that.

Incidentally, even OSMC’s founder\owner seems to have limited knowledge about how his box works, and he’s never once suggested that specific incompatibility.

So, assuming that the Vero and W7 will only talk to each other via SMB2 or SMB3, how do I make that possible?

As far as I know, all of the three SMB protocols are present in W7, except that SMB1 was possibly disabled last year by a MS hotfix.

Edit: Maybe SMB1 is still active in my W7 Ult64bit? If that’s the protocol that the WD devices use to talk to W7.

What i would try as a test … (assuming you’re running a latest version of Kodi on the Vero 4K box) is to change the SMB Protocol settings in Kodi (default is Minimum is SMB2 and Maximum is SMB3) so, change Minimum to SMB1 and reboot, and see if it works.

from the Kodi homescreen … Programs > OSMC Configuration > Services

example pic (i’m running CoreELEC (Kodi 18) on a 4K S905X Amlogic Android box)

Thanks, JoeySmyth - I’ll try that.
Cheers.

JoeySmyth: I tried your suggestion but couldn’t find an entry point that looked like your pic.

BTW, the KODI version on my Vero 4K box appears to be 17…something. I can’t see the whole number because I can’t get the display to fit onto my old Sony Bravia screen (this is another issue with the Vero)

AFAIK, the OSMC software keeps itself updated, but apparently doesn’t include KODI updates :frowning:

What are the chances I could dump the entire OSMC system and install only KODI?

can’t really offer anymore advice since i don’t use either a Vero 4K or OSMC

All my Raspberry Pi’s and Amlogic S905X Boxes running various distros … eg. OpenELEC, LibreELEC and CoreELEC can all access network shares from my PC and NAS without issues.

JoeySmyth, thanks again, I’ll talk to the KODI people about ‘rooting’ the Vero to dump OSMC.

Meantime, I want to reload the firmware on my WD media players. I’ve already used your excellent tutorial on how to reload 2.01.86 on my Gen3 TV Live Streaming player (WDBGXT0000NBK) and that worked fine.

Now I’d like to do the same operation on a slightly dysfunctional TV Live Gen2 player (WDBAAP0000NBK), running firmware 1.06.43.

I’m assuming that the FW version is ok, so if I can reload it, then reset to defaults, I’m hoping the player will work properly again.

Cheers.