What the heck is going on with Cover Art icons that I cannot change?

I ripped some movies to a USB drive, and the WDTV assigned some cover art to them before I even had a chance to search for the online metadata.  When I do get the correct metadata, the correct icon comes down as the .metathumb file, but the WDTV live continues to use its own icon (usually a frame from the movie - I have no idea where it came from).

I have tried deleting the .wd_tv folder and letting it rebuild.  I have tried deleting the files directly from the .wd_tv\thumb folder when I find them.  They keep coming back!

I have a similar problem with the folder.jpg file.  I have the art that I want to use for a folder there, but the stupid device uses one of the other files in the folder instead of folder.jpg, and I can’t get it to switch.

What in the world is going on???  How do I get this thing to use the art for videos and folders that I want it use?

If it’s say picking up english USA info and you have media suited to a different region you need to make sure the scraper is changed in the WDTV settings (if you plan to use that funcationality at some point). You can set metadata to manual only so the device will use whatever you have stored with your media as well. Are you using the media library? Try clearing it via the WDTV instead and refreshing it.

It’s in the settings under setup I believe.

did you ever figure this out?  i am having the same issue.

No - this is NOT figured out. :frowning:

The WDTV continues to use pictures that it got from I don’t know where.  They are NOT the cover art shown in the downloaded metadata, and they are not what the Metathumb file contains.  I don’t know where it is getting these icons from and I cannot figure out how to stop the device from using them! 

Telling the WDTV to rebuild its library did not work, forcing it by deleting the hidden .wd_tv folder did not work.

There are two possibilities that I’ve come across:

1- The JPG file that the WDTV downloads (and then calls a metathumb) may have an EXIF thumbnail embedded.  The WDTV may be showing that.

2- The movie file itself may have an ID3 thumbnail embedded that the WDTV is showing.

Ok, based on that, what do I do?  I’m not sure what that means in terms of steps to fix…

If they exist, just remove the embedded thumbnails using an EXIF or ID3 editor.  

my issue has to do with folders.  i have tried to delete .wdtv and to rebuild the media library.  for some folders it uses my folder.jpg or my 1.metathumb.  for other folders it uses the backdrop.  when i try to switch to a different folder.jpg, the smp just continues to show the same thumb.  as an example, in my kids movies folder i have a folder.jpg that should show a thumb with the word animation on it.  instead, it uses spongebob squarepants cover which is about 100  movies into the folder. 

AFAIK, “folder.jpg” files are ignored if there are ANY .metathumb files in that folder.

Could be wrong, though, because I’ve pretty much stopped using folder.jpgs.  Worth a try, though.

Here is what I found works for me:

Movies folder: had to use 0.metathumb (that is a zero!) file to get my movies icon to show up, since the movie files are all directly in the Movies folder (not in subfolders).

TV folder: have folder.metathumb for the tv icon; shows are all in subfolders.

TV show subfolders are all named like Chuck.mkv and contain folder.metathumb files.

TV show seasons are in further subfolders named like Chuck_Season_1.mkv, with their icons picked up automatically from the first show’s metathumb file (e.g., Chuck.S1E01.metathumb).

With some of these changes I did have to delete the wdtv.cas2 files and have them rebuilt in order to see the changes.

thanks guys, i stopped using jpg and went to metathumb.  then did a reboot and they began to show.  thanks for the help.

That appeared to be the issue.  Sometime recently, the DVDFab software that I use to rip my movies to my hard drive started including ID3 tags that it downloads from somewhere.  There is currently no way to turn that off (that I can find) :frowning:

I found an ID3 tag editor that enables removing the tag from an MP4 file.  Unfortunately it takes a long time to rewrite a multi-gigabyte file without the tag.

Thanks for the tip!!!