What is the state of my My Cloud Home device?

Hello,

My My Cloud Home device has suddenly gone offline, and I don’t know what state it is in, how to diagnose what’s gone wrong, or how to get it back working.

On the WD Discovery App, is just says that it is offline.

It was working a few days ago, then a backup to it failed, it now it has gone offline. The RJ45 LEDs at the back are both steady green. But the My Cloud Home doesn’t appear/isn’t recognised on the router that it is physically connected to, it just isn’t listed as a device (other devices do appear). I’ve tested the router port, and the cable, neither are the problem.

I’ve tried resetting it with the reset button - no change. I tried a hard reboot, by pulling the power plug out, and it returns to the same mysterious state. When it reboots, I can feel and hear the disk spinning up, and the LED at the front is initially bright. However, after a few seconds the LED goes much dimmer (it’s still on, steady, never blinks), and then that’s it, the last bit of feedback I get from this device to help diagnose its condition.

The User Manual isn’t giving me much help to diagnose this issue. Can anyone here help - has anyone else encountered a device in this state?

I’ve managed to fix this - not sure what the root cause was at all, but I tried a hard reboot (disconnecting power cord) with the ethernet cable, and it instantly booted. The LED was flashing, going through the boot sequence. After a few minutes, when it looked like it had rebooted, I reconnected the ethernet cable, and the device instantly appeared, 5 minutes later the filesystem available again. Phew.

Was it confused trying to do a check for firmware upgrade or something?