What is the default password for MyCloudEX2Ultra?

Please see attached.

I have tried all the old passwords I can recall
and those that are stored in RoboForm.

I have tried to find the default password:
none found.

I tried using the word password: does not work.

This site,


"Option B: 40 Second Reset (Reset with Power Off)
"The 40 Second Reset, also known as System Only Restore, will reset the following:
Admin User Name (default = “admin”)
Admin Password (No password by default)
Device Name (default = “MyCloudEX2Ultra”)
SSH (Secure Shell) User Name and Password (default = “root” no default password, new password enforced)

When I use the word root for the username, leave the password
field blank, and press enter, the next screen shows admin in the username
field and awaits a password, which is the same screen seen in the attached:

Please advise: how to get into my OldHomeNAS (MyCloudEX2Ultra)
after doing a 40-second reset ?

This was my old NAS for my pc backups.
And it holds Time Machine backups for my MacMini.

Many thanks for any help! :grinning:

Hi @JohnDohe,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting: