What have i done?!

My 3 day old 1tb my passport SE hard drive was going through the write delayed stuff, so I tried a number of fixes.

I changed the performance optimization thing through windows, and when that didn’t work, changed the settings back.

Then used the program ‘cacheset’ to change the cache. That didn’t work either, so I changed it back.

Then, I tried this…  http://www.gibni.com/windows-delayed-write-failed-solved/2

Messed with the registry and stuff, and it still didn’t work. So I deleted all the registry values I’d made, and right click uninstalled the ‘max128k’ file.

This is where I think I messed up, because now it’s never detected, but the light turns on, and I can hear the disk spinning.

As I’m writing this, the drive was detected as just ‘F:’

if I go to properties, the drive has 0 bytes of 0 bytes available, and if I explore the drive, there are no files. :expressionless:

I DO have files in it, I don’t really care if I lose them, but it shouldn’t be empty…

please help me.

this is so frustrating :frowning:

It might be a power supply issue. WD does make a power boost cable. That or a powered USB hub.

Previously, I had 2 different external Seagate drives that were just fine with power. One was 500gb, the other 1TB. 

Does this also explain the write delay error?