What does connection status ready mean

Under settings , general cloud access , connection status says Ready , cloud access is now available for your device. Whatever configuration i try (auto, manual etc) doesnot change. Tried to set cloud access off then on, reboot etc. Only when set to off , status changes to disabled, otherwise it is always Ready. A few days ago it was at relay connection, then changed. Any idea ?
Edit: even though it says Ready i cannot initialize cloud access - ie cannot register user to wd2go.com, or create code for cloud devices


“Ready” means the device is detecting an active internet connection. If you are unable to generate access codes or register users for the WD My Cloud service, then I would recommend verifying your router and ensuring ports 80 and 443 are open.

What DNS address are you using, if it is something like or what you router is set to its more than likely not correct.  I use Century Link and found out the true DNS for the My Cloud to access outside your local network is totally different than my local DNS (Home Network).  I went to the website to find out the true DNS address.  Change this address in the My Cloud settings and it should work fine.

I would never think of that as a solution , but changing the dns in mycloud dashboard network settings solved the problem for me.

i set the dns to opendns server ip address, and disable and enable cloud access, and able to signon to wd2go and generate code for my device.

also learned that there is no need to generate a code for the device that connects to the home network. my ipad which before was unable to logon to mycloud device, immediately logged on from home network…

still cannot understand the reason behind not using my home router’s dns which is the same as gateway address, but thanks RKFRAZIER for the tip…