Western Digital Ultrastar DC HC650 not detected in Unraid

Hi - I added 3 new 20TB Western Digital SAS drives (Western Digital Ultrastar DC HC650 WSH722020AL4204 20TB 7.2K RPM SAS 12Gb/s 4Kn) to my HP Z840 workstation, but they don’t show in Unraid. The original 1TB SAS drive shows OK. The onboard Serial Attached SCSI controller is a Broadcom / LSI SAS2308 PCI-Express Fusion-MPT SAS-2 (rev 05). I have also tried attaching the drives to a HBA-enabled HP H240 SAS controller card with the same results. The log file shows that Unraid sees the drives, but the 20TB WD drives are all listed as “Unsupported ZBC host-managed device”. Any advice gratefully received

Hi @Steviewunda ,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

1 Like

Thanks K - yes I opened a support case. I have since updated the firmware on the H240 controller and tried a Windows 10 install (same as Unraid - drives not detected) and an Ubuntu 22.10 install - which DID detect controller and drives, and I was able to format and use the drives in Ubuntu.
But I want to use Unraid, so I will sell the SAS drives and replace them with SATA drives - do you know if the 18 TB WD SATA drives would be compatible with the onboard controller in my HP z840?

1 Like