Western Digital SuperSpeed USB 3.0 PCI Express Not Working. Not being recognized by Windows

The card itself seems to be working as the white light is on and my usb 3.0 Western Digital portable HD starts spinning.  Problem is windows never sees the hardware.  The drivers installed but I get the error no USB 3.0 host controller when trying to start it.  

My motherboard is kind of old so maybe a compatibility issue?  I disabled the speed spectrum option as recommended but still no hardware found.  The one mistake I made initially was installing hardware then installing drivers but I don’t see how this really impacts me.

Any suggestions?

Here is my mobo btw _



Did you verify the compatibility between the board and the card with the motherboard manufacturer?

The problem is not necessarily with your motherboard.  Maybe you have a defective USB 3.0 card.  Regardless of what the drive seems to be doing, it sounds like your USB 3.0 card is not working.  Is there another computer you can try the card in?

I would be surprised if Asus would lift a finger to help you at this point.  Their support forums are hardly active, and your motherboard is certainly long out of warranty.  I suppose it couldn’t hurt to ask, although there shouldn’t be a compatibility issue.  A PCI Express device is supposed to work in a PCI Express slot, end of story.

I ended up buying another card and still get the same issue (not recognized at all - YET the card is powered on and lighting up).  Any bios settings to check again or drivers to update?  This is very fustrating b/c I agree - this card should work.

I doubt any BIOS settings have anything to do with this.  My motherboard is sufficiently old (Asus P5E3 WS Pro) that the last BIOS update was around three years ago, well before USB 3.0 products hit the market.  Any attached USB 3.0 devices don’t show up in the menu of drives in BIOS, and are not available as boot options.  Only devices attached to the motherboard’s own USB 2.0 ports show up in BIOS/at boot time.  Even so, I can access USB 3.0 devices through the card once the OS has started up, whether it’s Windows XP, Windows 7, or Ubuntu 10.04.

 You probably already thought of this, but will the MyBook show up when attached to one of the motherboard’s built-in USB 2.0 ports?  Occasionally, the wiring harness that connects the motherbord to front-panel USB 2.0 ports does not quite work, which is why “attach to a built-in motherboard USB 2.0 port” is usually part of troubleshooting.

The hard driver works perfectly fine on the 2.0 usb ports.  It seems that the PCE slot is not registering the card and not allowing the usb 3 controller to be noted under device manager.  Anything I can try?

If I understand correctly, you are not seeing any USB 3.0 devices at all in Device Manager.  That’s odd, especially given this is your 2nd USB 3.0 card.  You should at least see an entry with the little yellow “unknown device” symbol.

I didn’t even have to install drivers for my USB 3.0 card (unbranded one purchased from DealExtreme).  Windows detected the new hardware, downloaded, and installed drivers automagically.

Please post more specific info on your USB 3.0 card.  It might help to know what you’re working with.

my card is unbranded too althought the first was a western digital brand.  i checked again and i do see a unknown device icon althoughim not sure thats bc of the usb card.  anyway to check what this unknown device ties too?  i try to update the driver manually and point to the usb 3 driver but windows says cant install.  any suggestions?  i can try to take the card out to see if the known device goes away?  weird.

btw the card is from monoprice but again the western digital gave me the same reaction

EDIT - I removed the card from my pc and it still shows unknown device so that yellow warning is NOT related to this usb pcie card.  Wow - i can’t believe I can’t get my mobo to recognize this.  Very fustrating.  Should just be plug and play.  It has to be a compatibility issue with my mobo.

EDIT #2 - Someone on the asus board mentioned that the USB 3.0 cards I have seen all call for full compliance with PCI Express Base Specification Revision 2.0. This means a PCI Express 2.0 x1 slot not a PCI Express x1 slot.  

I probably don’t have a PCIE 2.0 x1 slot just the normal one.  Wonder if I can apply a soft update to get 2.0…

Someone on the Asus board is misinformed.  PCI Express gear is all (in theory at least) backward-compatible.  That is, a PCI Express 2.0 device will work in an older PCI Express 1.1 or 1.0 slot, but at reduced speed. 

Boilerplate like “Supports PCI Express Base Specification Revision 2.0” is just bragging that the card can, in theory, ship data at the speed of a PCI Express 2.0 slot, not that it is incompatible with the older slot type.

In reality, you will not come close to the limits of PCI Express 1.0.  An external hard drive will hardly push 1.0 Gbit/s on its best day, and PCI Express 1.0 can handle 2.5 Gbit/s.

Do you have another PCI Express slot you could try?  A 1x card should still work in a larger slot, for example 4x or 16x.  It does on my motherboard.

Unfortunately, there is no way to “update” PCI Express 1.0 to 2.0.  The electrical specs are different.  You would only get PCI Express 2.0 with a new motherboard.

Your problem could just be one of those weird, rare cases of incompatibility in gear that’s supposed to be compatible.  It happens.

Really appreciate the help btw.

I actually do have another x16 slot but that’s where my gfx card goes so if I replace it with the usb card, I won’t get a picture.  This would atleast let me know if it’s the card or the slot b/c my gfx card works perfectly fine so I know the x16 slot is OK.  If you can think of a way to still have a pic and take out my gfx card, lmk.  I don’ t believe that mobo has a onboard video card and it only has 1 16x and 1 1x slot.  It has 4 PCI slots (which  I rarely use).

EDIT - I just bought a PCI to PCI express adaptor so I can try another PCI slot to see if maybe my PCIe slot is not working.

Some good news - with the pci adaptor plugged in, the card for the first time is registering on my OS.  HOWEVER - it shows the 3.0 usb controller with a yellow ! and says the device cannot start.  I went to update the driver and it says I have the latest.

Getting closer here - any suggestions?

…and it works!!!  I basically replugged everything into another PCI slot and it works fine.  No more driver issues.  Speed is not as fast as I wanted but still twice as fast as USB.