Western Digital SSD Dashboard Crashes (Version: 2.4.0.0)


#1

Western Digital dashboard does not work whatsoever, the newest version. everytime I try to load it up it crashes back to desktop. is Western Digital planning on fixing this. this software is very dangerous especially when it updates firmware.


My system specifications:

“CyberpowerPC”

-Board: ASUSTeK Computer INC. “M4N68T-M-V2”
-WD SSD Blue 1TB (also a internal 4gb wd blue backup 4tb HDD)
-Ram DDR3: 16GB (2 x 8GB) Kingston Technology HyperX Blu Red Series 1600MHz OC “KHX16C10B1RK2/16”
-Video Card: EVGA GeForce GTX 960 4GB FTW Model
-750 Watt PSU CORSAIR Enthusiast Series “TX750”
-Acer 20’“1600x900Max Rez” LCD (Acer X203H bd 20-Inch LCD Monitor)
-Phenom II X4 955 Black Edition 3.2GHz AM3/DEEPCOOL GAMMAXX 300 CPU Cooler 3 Heatpipes 120mm PWM Fan
-16gb set pagefile (16,384 )
-Win 7 64bit


More PC Info:

-CPU Rating: 7.3

-Ram Rating: 7.5

-Video Card Rating: 7.9

-Gaming Graphics Rating: 7.9

-SSD (wd blue 1tb ssd) Rating: 6.9

-Redragon M901 MMO Gaming Mouse


#2

Just an FYI - I have 3 PCs each with WD Blue SSDs and have no issues running 2.4.0 version of the Dashboard. All on Windows 10. It just seems to me there might be some issue with your OS and not the WD Dashboard.

Just sayin’…


#3

well i have windows 7 not 10 its say on the site it works with win 7 and 8 as well

Supported Operating Systems
  • Windows 10 32/64-bit versions
  • Windows 8.1 32/64-bit versions
  • Windows 7 32/64-bit versions

#4

I understand it will work on Windows 7, 8.1 and 10. What I meant was there might be an issue with your installation of Windows 7.


#5

I seriously doubt it. i tried this on 6 win 7 pcs I just went on in purchase a Samsung ssd that fix the problem I’m sending the Western Digital back


#6

thx for the help anyways i hate crappy software


#7

I have the same problem !!! I can not use my SSD, I just buy it…


#8

Same problem with 2.4.0.0. on W7 64bit.

This “fixed” it:

Device Manager > IDE ATA/ATAPI controllers > AMD SATA Controller
Right-click on AMD SATA Controller, select Uninstall.
In “Confirm Device Uninstall” dialog box, check “Delete the driver software for this device.”
then click ok.

I had to reboot three times (because of the number of SSDs / HDDs on this system?)

This leaves you with the Microsoft supplied
“Standard AHCI 1.0 Serial ATA Controller”
under IDE ATA/ATAPI controllers.

Dashboard works, CrystalDisk works, and SMART is available on both.
Performance looks the same as when AMD SATA Controller was installed,


#9

Thank you for your help, but in Device Manager > IDE ATA/ATAPI controllers, I have Intel® PCHM SATA AHCI Controllers 6 port

Thanks again I appreciate your Help


#10

You are welcome.
I assumed people would realize I was referencing AMD based machines.
HOWEVER, have you tried uninstalling the Intel driver
(and deleting the driver files)
and letting the Microsoft supplied driver replace it?
It would be an interesting experiment.

Oh yes,
I forgot the usual disclaimers / cautions.
Backup your system prior to experimentation.