Western Digital Passport Studio 1TB "The disk inserted was not readable by this computer."

My Western Digital Passport Studio 1TB (P/N: WDBK8A0010BBK-00) has started giving me the message “the disk inserted was not readable by this computer” every time I connect it to my Mac computers using Firewire 800.

I have no reason why, and upon testing it with disk utility there doesn’t seem to be any problem, and I can use it like before, I can reformat it and everything. It seems to work just fine, so why do i keep getting this message over and over again upon connecting it to my Mac computers?

There are no current firmware updates available, and the universal firmware updater tool provides and older firmware (at least it claims so) than what’s currently on my Passport Studio in the first place, so it seems silly trying to re-flash the firmware if it gives me an older firmware.

I have the Turbo+ Drivers installed, I have tried the SmartWare tool and things like that and they don’t seem to find any thing suspisios.

Have you tried using USB? Do you receive the same error message?  If you do not receive the message using USB something may be wrong with the Firewire ports, in this case you may contact WD for a replacement.