Western Digital MyBook World WD5000G032 Recovery


I’ve done a lot of searching around the internet for help on this and am not totally sure the best place to ask this question, but this seems like a good place to start.

This model external drive uses a Western Digital Caviar SE 16 WD5000AAKS 500GB hard drive, and like many others I have found on the internet, the blue light on the enclosure would no longer turn on, causing the drive to no longer be recognizable to any computer. It appears this may be due to a power supply problem or other issue on the small circuit board that runs the external drive.

Many have had luck removing the drive from the enclosure and connecting it directly to a PC (it’s a SATA) to be able and retrieve data.

So I did this, and I can see the actual drive in windows under computer management, but it shows it’s not initialized. I understand these drives are formatted for Linux, and tried using a driver I found recommended in one of the support threads I found. (this is what is was: http://www.fs-driver.org/download.html)

I’ve also tried using Easeus Drive Recovery Program, and it sees the drive, but searches for files and partitions forever (like 24 hours continuous) with no luck.

Does this mean that maybe in my case the actual drive is fried? Or is there something else I could try (or am not doing properly) and maybe the data is still there somewhere? Any suggestions would be appreciated. Thank you

I have the same problem, and as far as I know Easeus is the best in the market right now but the recovery process would take appromixly between 3~6 days (depend on the size) or at least that’s what I heard.