Western Digital My Passport 1TB USB 3.0

I have got western digital My Passport 1TB USB 3.0

Suddenly I’m not able to access the hard drive quickly. It takes ages to be mounted. I can, however view the data, but when it comes to transferring data into it, I’m not able to do that, it suddenly gets crashed. To elaborate more, I’m not able to even copy the data from it as it gets stuck at a particular point. All the data inside the hard drive is important and I cannot afford to lose it anyhow.

Tried to access using MacDrive in Windows but it’s the same thing. Tried it on multiple Macs.

Need help to backup data so that I can claim a replacement! Thank you! :slight_smile:

Sounds like a data corruption problem, you can probably recover most of it with a data recovery program. Just in case you can also use the repair disk option from the disk utility app, check the link below for the steps. 


Your hard drive could have logical problems - for which software could be a great help. However, if your drive is having physical problem (ie pending head damage, platter damage of any kind) - software recovery could lead to potential permanent data loss.

Proper procedure would be to image your drive by avoiding any interaction with bad sectors first, and then pull data off the image. NOT the original. Pm me if you need more info.