Western Digital My Book Essential 3TB USB 3.0/USB 2.0 (corruption problem)


#1

I copied all of my MKV’s to a new 3tb drive over the past couple days and started watching both blu-ray and dvd rips without any issues whatsoever. This morning, I turned on the WD and tried to play any movies in various folders at a certain depth to no avail. The message I get is that the player doesn’t recognize the file format. Oddly, it’s all files past a certain depth in the folder structure. For instance, I have a layout like:

Adults\

---- Movies\

-------- A-F\

-------- G-K\

Kids\

---- Movies\

-------- A-F\

-------- G-K\

, etc

As of this morning, anything past say R-V in adults and all of kids movies are now unplayable.

This is a brand new drive and the same *kids* files copied to a WD Essentials 1.5 tb drive with a classic WD TV Live have never had a problem. Did my TV Live Plus just kill my new drive? Any thoughts?

Seperate question – can it be made so that a WD player has read only access to a USB drive?

  • Brian

#2

The files won’t be playable until the WDTV has done scanning the drive – that’s why the ones prior to a certain point work, and the ones after that point, won’t.  The ones that won’t play haven’t been checked yet.

You just need to be patient and let it finish scanning all 3TB.


#3

Not sure if it is one or the other or a combination of the two.  I have purchased the 3TB drive and had the same problem.  After transferring my whole library from a 2TB and 1TB drives to the 3TB I plugged it into the WDTV Live and it scanned and played the movies.  The next day I went to continue a movie I was watching and it gave me the same error stating that it didn’t recognize the format.  I tried to play move I previously played and got the same message.  A couple of the folders did work but about 3/4ths of the drive are now listed as corrupted and will not play.  I plugged the drive up to my Win 7 PC and it states 1.43GB free of 746 and in the red.  When I go into the folders of the files that will not play the files state that the size of the files are listed as 0KB and will not play stating that the files are corrupted and can’t be played.  So I formatted the drive and started the process all over again and it worked for a few days then guess what happened.  THE EXACT SAME THING AGAIN!  All files listed as 0KB, corrupted, and won’t play.  So is it the combination of the WDTV and the new 3TB drives that there is an issue or is it only one of them?  I am heading back to Best Buy to exchange the drive and see what happens.  If this happens again then I know there is a major issue with the combination of the WDTV Live Hub and the 3TB drives.


#4

I have the same problem , with my WD TV HD Live (firmware 1.04.10)

I copied all movies from my WD MyBook 2TB USB2.0 to my new WD MyBook Essential 3TB USB 3.0/USB 2.0

and many of my movies is not visable.

I hope a new Firmware would resolve this problem.


#5

I sent an email to WD support to see what they had to say but I haven’t heard back yet.  I’m just glad I didn’t format the previous drives so I didn’t lose anything.  1500 movies are a lot to rip!  LOL


#6

I’m sorry to hear that I wasn’t the only one. Simply waiting for the Live to “Scan” didn’t solve anything. A check of the drive on my main rig proved that the drive/files were then corrupt.

I just don’t trust the WD box with this drive anymore and have since moved to the drive to be used by an HTPC w/ 3.0 support. I’ll still use the live as a media renderer.


#7

Im having the same problem also and very surprised as they are both WD products.  With the recent firmware updates I though for sure there wouldn’t be a problem.

Is there any news of any fix on this matter?  

  Really hope they fix this with a firmware update. 

Also fix the **bleep** folder icon appearing right in the middle of the cover art in thumbnail mode!  so annoying.


#8

You have probably read the sticky at the top of the page. (NOT)


#9

LOL  thanks so much for pointing that out.

Sorry no I did not notice that as I searched in google for this topic and found it.  I never went into the main forum page.


#10

Same problem here.  When I plug the external drive into my pc it now says the drive must be formatted.  The WD Live player sees the drive and plays the files, but lots of files are now corrupted and the player stops playing them right in the middle of a movie.  How lame!

Formatting the drive and starting from scratch is not really an option as I have nowhere to offload 2 TB worth of stuff.

I tried running SpinRite 6 on the drive, but it failed with an unrecoverable error while reading the drive.

When I try to run check disk in windows, it gives me some unreadable drive critical error.

This blows!


#11

Since you don’t have space for 2 TB of data to re-format, it won’t work for you, but it might help others.  

What I did was create 2 partitions 1.5 TB each and labelled them PART1 and PART2.

Now when I select “USB2”,  I have 2 choices “PART1” and “PART2”. Once I select “PART1” or “PART2”, then I see the directory structure on the partition.

(I doubt it was scanning issue in my case - I let it go for 24 hours and it still failed to play movies). 

Also, I had read that WDTV Live cannot read 4K cluster size created by Windows 7, and 512 byte cluster size cannot go beyond 2 TB … so only options for partitions greater than 2 TB, are 1024 byte and 2048 byte clusters (These are not default settings when creating larger partitions)