Weird problem with WD My passport - some videos won't play

I have the weirdest problem. I have WD My passport external hard drive 1TB and I like it. Until a couple of days ago when it started to cause me troubles. I have a good amount of videos on it. I was watching some of them on my laptop, but then came to a couple that wouldn’t play. I thought it’s just these few and kept watching. But there were more. Maybe half of the videos won’t play. I usually use GOM player - it gave me the “find codec” error, but of course, it couldn’t find them. Then I tried with two other players and I was getting an error that the file is corrupt or missing or there are bad sectors. The weird part comes when I try to play those files on my PC - they play no problem. I can’t understand how’s that possible if the file isn’t complete - I thought it shouldn’t be able to play on either of the computers. Both computers run Win7. I tried to unmark the read-only on the HD but it’s marked when I unplug and plug the drive.
It’s all a bit complicated but I hope someone could help me. :slight_smile:


The passport is just an storage device, it wont prevent you of playing any particular file.

Have you tried copying the files again to the drive?