Webinterface not reachable after Firmware Update


modelname ends with “-10”. Is it a new v2 version?

Thank you very much!


I’m afraid I don’t know. The -01 ending came from the first description of the Gen2 models:

I’m not sure if WD publish device codes anywhere.


I had the chance to check o original 2TB WDMyCloud and there are different partitions.

md0, sda1, sda2, sda3, sda4, sda5, sda6, sda7

sda8 is missing, could that be?

I have copied the different partitions but when I compare there are different sizes like in Bennors tutorial, so how I should copy the sda’s`?

Best regards



I spoke with the seller of my chassis and he told me the Firmware was 4.0x :(. He bought it in March 16 at the WD Store.

Best regards


What unbricking process are you using?

In the process I used (posted above) one manually creates the partitions (eight of them) at step 6…

mkpart primary 528M 2576M
mkpart primary 2576M 4624M
mkpart primary 16M 528M
mkpart primary 4828M -1M
mkpart primary 4624M 4724M
mkpart primary 4724M 4824M
mkpart primary 4824M 4826M
mkpart primary 4826M 4828M

It is why one has to run the GPT fix first before creating the eight partitions.


I’m using your tutorial, but yesterday I had the chance to make a clone of a new 2TB MyCloud V2 and when I mount the image there is a different partition Layout that yours respectively to a V1 model.

Never mind, my modell seems to be a V1 and this idea helps me nothing at all.

Best regards

Here you can see the partition map of a V2 model.

The Data partition is in v2 sda2 and not sda4.

Best regards

You need to figure out which My Cloud version you have, either v2.x or v3.x/v4.x. It seems you flip back and forth on which My Cloud version you think have in this thread unless I’m reading things wrong. My directions were for the v3.x/v4.x My Clouds. I don’t have a v2.x My Cloud so I don’t know its layout/structure or how it would be unbricked.

What is the FULL model name from the bottom of the My Cloud enclosure?

If the previous person bought the My Cloud from WD on March 16, 2016 then its entirely possible they have v2.x but without knowing the full model number its hard to know. Further I would also question the seller why they were selling just the chassis. Was the My Cloud damaged in some way so they sold the chassis but kept the drive?

Another way to try and determine the version is if one is able to unbrick and load the Dashboard with the v3.x firmware, enable SSH and then connect to the My Cloud using SSH. Then run the following two commands via an SSH terminal window:

cat /proc/cpuinfo cat /proc/meminfo

Gen2 (v2.x) will have the following processor and RAM:
Marvell armada 370 (2core, 800MHz)
512 MB Ram

Gen1 (v3.x/v4.x) will have the following processor and RAM:
Mindspeed Comcerto C2000 (2 core, 650MHz)
256 MB Ram

1 Like


thank you for your help!
I checked the cpu and it’s a V1 :(.
When I look on the back it’s a WDBCTL0040HWT-00, not a 6TB.
Too bad :(.

Now i have choosen a old Image with version v03.00.03-413. After a full reset I upgradet via SSH to version v03.04.01-230 and after that via SSH to the newest one. Now it works :grinning: but I don’t know why.

Thank you very much and have a nice weekend.

Best regards


Have the same WDBCTL0040HWT-00 enclosure. It was initially a 4T My Cloud that came with an early version of the v4.x firmware. Internal 4T drive got damaged so I replaced the drive. First ran a 250G drive in it, then a 1T drive.

Here my 2 cents:
Ever since I had bought a Western Digital My Cloud System with 4 TB of Backup space, I had problems with it: after some hours, the system was unreachable over the network. Several firmware upgrades later, the problem has aggravated, and the system was reachable only for 10 to 20 minutes after powering it on.

In my blog post https://oliverveits.wordpress.com/2016/10/29/resolving-networking-problems-performance-problems-of-a-wd-my-cloud-nas-system/ I have summarized the measures I have taken to get it back to life.

In short: by enabling SSH and using top, I have found out that the system was in a heavy swapping mode because of missing memory, which had caused the problem on my side. I also could see that the system was spawning 10 apache2 processes, which were consuming almost 100% of the physical memory, so other processes were starved.

As a resolution, I have changed the number of apache2 processes to a reasonable number (3 in my case). Since then, the disk is silent (it was working heavily and audibly before), and the web interface responsiveness is higher than ever before.

To perform the changes, log in per SSH as root, edit the file /etc/apache2/mods-available/mpm_prefork.conf.

Before the change, I have found following relevant content in the file:

StartServers          2
MinSpareServers       2
MaxSpareServers       10
MaxRequestWorkers     10
MaxConnectionsPerChild  10000

I have changed this to:

StartServers          2
MinSpareServers       2
MaxSpareServers       3
MaxRequestWorkers     3
ServerLimit           3
MaxConnectionsPerChild  10000

This was the resolution that had helped in my case; a resolution I have not found in any of the Forum posts.
I hope this is useful information for someone.


is it possible to shrink a 1TB Image “factory Default” to i.e. a 500GB HDD?
I would shrink the big data partition to about 450GB and copy the Image via following command

“dd if=/dev/sda of=/DataVolume/shares/Public/mycloud1tb.img bs=1M count=5000”

Afterwards i would restore the Image to a smaller hdd.

Thank you very much!

Best regards

If you are unbricking and replacing the older first generation v3.x/v4.x single bay My Cloud hard drive with a different hard drive (including one that has a different size) there is no need to “shrink” the drive. Just follow the directions to properly partition the drive. Once unbricked generally one should run a full system reset (40 second reset via reset button on the back of the My Cloud or a System Restore through the Dashboard > Settings) to correct the incorrectly reported hard drive size.

See the following link by user Fox_exe that details how to “unbrick” a first generation v3.x/v4.x single bay My Cloud unit:
English: https://drive.google.com/file/d/0B_6OlQ_H0PxVbzZac0plbkZKeGM/view
Russian: https://drive.google.com/file/d/0B_6OlQ_H0PxVakNZMjFvdzloRVk/view

Those directions have a slightly different method of fixing the incorrectly reported hard drive size post unbricking.

Hi Bennor,

nice Tutorial :), but the links (Google Drive) are down.
Do you have the tar.gz Image Files?

Thank you very much

Best regards.

That’s one of the problems with many of the unbricking procedures, finding valid links to the files needed. You could try using either the v3.x or v4.x file Fox_exe has up in the Backup folder of the Google Drive that hosts those instructions: https://drive.google.com/drive/folders/0B_6OlQ_H0PxVNTN6c2F4SXEwQVU

Hi Bennor,

Thank you very much! It worked with the V3… backup. How can I make a Backup of my (kernel.img, rootfs.img, config.img) to play back a Image with the newest Version?

Thank you very much!

Best regards

A subforum search, using the magnifying glass icon upper right, for creating a backup img file brings up several threads…


The command goes something like this to save the img file to the Public Share on the first generation single bay v3.x/v4.x firmware My Cloud:

dd if=/dev/sda of=/DataVolume/shares/Public/mycloud.img bs=1M count=5000

Note: You probably want to do this on a My Cloud that doesn’t have any user data copied to it yet and you probably want to do a 40 second reset via the reset button on the back of the My Cloud, or use the Dashboard >Settings > Utilities > System Restore to reset the My Cloud to default values, or use the Dashboard >Settings > Utilities > Quick Restore which erases all user data and resets the My Cloud to default.

Hi :),

I have tried it this way:

Works nice! Thank you!

Best regards

Hi All, I came across this thread and I am confused.
I have a WD My Cloud with a single drive of 2 TB. I want to replace it with a 4 or 6 TB drive.
What do I have to do ? Is there a clear 1,2,3 steps listed anywhere. I saw all sorts of posts regarding all sorts of models and various steps.
I know a little scripting and ssh is not a stranger but would rather do this the Windows GUI way if possible.
Is there a procedure I can follow?

Many thanks and sorry for reviving this old thread.

There are a number of thread discussions that cover replacing or changing the My Cloud hard drive with another hard drive. Any of the unbricking procedures will work when replacing the My Cloud hard drive.

As indicated earlier in the current thread discussion user Fox_exe has created a set of directions for unbricking a first gen (v3.x/v4.x) single bay My Cloud and a different set of directions for unbricking the second gen (v2.x) single bay My Cloud.
First Gen: https://drive.google.com/drive/folders/0B_6OlQ_H0PxVZTBtM3EyRVhDVms
Second Gen: https://drive.google.com/drive/folders/0B_6OlQ_H0PxVRXllYjY5RG1CZEU