Web UI damaged, no ssh, nfs and samba working -> how to gain ssh access?

Hi all,

after upgrading to v4 firmware, I tried installing transmission via apt-get which seems has damaged the Web UI:

14:31:27:~$ telnet 80
Connected to
Escape character is ‘^]’.

301 Moved Permanently

Moved Permanently

The document has moved here.

Connection closed by foreign host.

And ssh is not enabled…

Any idea how to recover access to the UI or ssh? I want to downgrade it.

I once recovered a totally bricked mycloud using a linux tv set top box  and the dd command, but I really prefer not to disasamble it again…

By the way, I’ve already tried doing a system resetting using the reset hole, and nothing changed.


apt-get won’t work with firmware v4. V4 needs special builds patched with 64k pagesize memory. http://community.wd.com/t5/WD-My-Cloud/Building-packages-for-the-new-firmware-someone-tried-it/td-p/768007

For your case since there’s no ssh, you have no choice but to dissemble again.

1 Like

Thanks Nazar78!

I really regret not seeing the “important notes” in the sticky post.

I kept it in v3 for a month and today a relative of mine came asking questions about programing stuff… and I was so boring waiting for him trying codes on his computer …  and I forgot to backup my shadowsocks server… should never do things unfocused…