Web access failed

It was working before, but after I restored my MBL, after I registered with my email again, go to wd2go.com and enter my email and password, the drive shows up, click the drive, page goes to an error “Server not found”, I tried it on different computers, same result. Is there away to fix it or do I need to restore again? I just had XXXGB copied into it I really don’t wanna restore.


First of all check the MBL user interface Settings > Remote access and see exactly what Conectivity Status is displaying.  (see the printscreen here: http://www.flickr.com/photos/29878505@N04/6250886518/ ).

If it says “Failed” then it seems you have the same problem as I do: I can’t access MBL using WD2go, WDphotos, also can’t register an email for Remote Web Access.

WD Support suggested a factory restore. I didn’t do that because I don’t have where to move all my data stored. 

But I found here on forum a similar story told by user mudkiphttp://community.wdc.com/t5/My-Book-Live/Remote-Access-displayed-as-quot-Failed-quot/m-p/259838#M4383 )

He performed a factory restore, MBL worked fine for a couple of days then again MBL failed to connect to the internet.

Well, first of all check the MBL’s conectivity status!


where is your mbl set up? if you have a lot of network drive/shares on a network, you might be having a problem resolving the dns - if you’re using the drive name to connect.  try connecting through the ip address.  once I did, I had no more issues not being able to connect.