WDTVLive Hub Firmware Glitch


First time in the forums so be gentle… :slight_smile:

Just curious if anyone else is having issues with screensavers on the WDTVLive Hub. The last time things worked properly was with the 2.06 firmware. Both 2.07 and 2.08 seem to have an issue where when the screensaver starts, music playback stops. Doesn’t matter what delay is used or the type of music file playing, or the source of the music. Screen goes black and playback stops, then the screensaver kicks in. Still happens after rebooting, reseting, repowering, regurgitating and repainting.

I reported this as a bug with 2.07 and sadly it is still present in 2.08 - at least for me. I’ve since rolled back to 2.06 and things are working beutifully yet again. Pretty sad as I love to stay current with the firmwares and you’d think that WD would have fixed this by now since the kind gentleman at tech support did say that he would escalate my issue to the development team… really, he did… honest.

Anyway, just curious if anyone else noticed this bug.



Thanks… I’m glad to see tthat it’s not just me. Unfortunately other people having the same issue definitely means ongoing bug in the firmware. The workaround that was mentioned to use dthe WD Logo screensaver didn’t seem to work either. Didn’t matter what was set as trhe screensaver or what was playing - the audio always stopped. Just have to wait and see i guess. Cheers!

I had this problem as well.  I found that If I disabled the screen saver, saved the settings, and re-enabled it the issue was corrected.

Thanks! Maybe I’ll give that a whirl. What screensaver did you have set initially? WD logo… Slideshow…?

RWPHAN wrote:

Thanks! Maybe I’ll give that a whirl. What screensaver did you have set initially? WD logo… Slideshow…?

Random photo slide show

if you set it to WD Logo glitch does´t appear

I have the same issue and had it in the previous fireware upgarded  (I rolled back). I have tried all the suggestions plus a reset of settings and the issue persists.

WD guys, why hasn’t this been fixed? Several other people have comented that they reported (as I did) the issue in last upgrade.

Are not peple who use the player for music and photo displays as important as other users?

When can we expect a fix?

Well, according to WD, it *was* fixed in 3.00.28.


It doesn’t do that to me anymore…   Maybe you need to do a factory restore after the upgrade…

Thanks for the info Tony. I have been sitting at 2.06.10 as I love haing a directory of art as my screensaver scrolling  on screen througout the day and was unwilling to give that up. Ill give 3.00.28 a try, of course prepared to roll back in case it doesn’t solve it for me



My error and apologies to WD support staff. When I did the previous upgrade it upgaded from 2.06.10 to 2.08.13. I did not notice that and had expecxted it to update the latest version, then 3.00.28.

I have now upgraded to 3.01.19 and the problem is gone, I can now happliy listed to music while the slideshow runs.

Of interest I had to run the upgrade process twice. It initially upgraded to 2.08.13, then on 2nd attempt it went to 3.01.19