Wdtvlive doesn't show up as storage in windows 10

#1

Hello,

I’ve always had my wdtv live setup so I could access the hard drives connected to it through windows file manager. It showed up under the network, as storage. I now upgraded to windows 10 and the WD doesn’t show up anymore. After adjusting the workgroup name to homegroup, I got it to show up under ‘media devices’. But it still doesn’t show under ‘storage’. Does anybody have any ideas on what I could try? I really have no clue where to begin.

Thanks,

David

#2

Hello and welcome to the WD community.

I have  WDTV Live Hub and i am able to see the storage on it, try to check if the device is on the same workgroup as the computer and also try to see if there is no software blocking it.

#3

Thanks for your answer. The device is on the same workgroup as the computer and is not blocked by any software. It does show up as ‘media device’. But the attached usb disks don’t show as storage though, so I can’t transfer files from my computer, which is very inconvenient…

David

#4

Update: I used the WD discovery software and managed to map the usb-drives which are attached to my WD TV live as network drives. This went without a glitch. They still don’t show up as storage under network, but now I can access them again from my computer, so this solved it for me.

David

#5

Just registered to say “thank you”. Your solution really helped. I installed W10 last night and this was the only thing I couldn’t get to work correctly.

#6

Hello, I am having the same problem. I have a wdtvlive with a wd my passport external storage attached to it. Until last week, I could connect via my windows 10 file system to the my passport and transfer files there. Now for some reason, I see the wdtv icon on my networking window, but the my passport is no longer showing. I didn’t change anything, I have windows 10 home and it is really a pain to have to connect the external drive to my pc every time I want to transfer files. I know it is possible to watch content the other way around, from wdtv connecting to my pc, but I prefer to attach an external device to the wdtv as a source of content because the quality is better. Does anyone have any ideas on how to solve this issue? Many thanks!