WDTV & Windows 10 (Build1703)


#21

All I can add is that my solution of using my router as the master browser is still working fine. Its a BT Hub 4.0 and is pre set to create a workgroup called HOME and be a master browser, so all I needed to do was switch my PC’s and WDTV’s to HOME as a workgroup rather than the default WORKGROUP as it all started working again. This was all discovered more by luck than judgement, any help from Microsoft even with a Brother that works at head office in Seattle!!!


#22

@WatchBackup

Your post is quite alarming because the other day I finally answered the nag screen to check my privacy settings to get this 1703, and my Win 10 has been completely shut down for a few days. But, I just turned it back on and watched in Win Update screen the update finish downloading and start preparing PC for update. So, I have turned off the PC. (I am using my Win 7 right now.)

Is there any way to prevent this update from getting installed; I looked in Win Update and there doesn’t appear to be.

I am unclear what this problem is:

Does 1703 cause non-sharing of ANY sharing of any devices, or just the PC-only with the WDTV? Everything was and still is originally shared via my Win 7.

Will this prevent my WD NAS from being shared to WDTV?

This is so darn confusing and frustrating.


#23

To my knowledge, once you have started the update you have to finish, but re start and see what’s happening. As to your NAS? not sure if that will be affected or not, it depends on which device wins the master browser election and is calling the shots sharing wise.


#24

I set my router to be Master Browser years ago and those MB issues with WDTV are history.

So does 1703 mess with the Master Browser conditions and cause WDTV to (erroneously) be MB again?

I’m thinking I will need to let update install and just cross my fingers that all will work as in the past. since my MB setting is from router and not PC.


#25

I’d like to support IvanR8’s solution with one minor correction… DO NOT RESTART!

So something weird in the protocol stack is causing the Net Broadcast to close.

I figured out the the NetworkID wizard just asks the question so it can figure if you are a Domain or a WORKGROUP… and always starts from the default of . my computer is part of a busines…BLAH BLAH,

If you choose part of a home network…even if you are already part of MYWORK or MSHOME… it will change it to WORKGROUP, much like doing a network troubleshoot changes it to DHCP :frowning:

But what I did notice is that after you press that button, it shows up on the WDTV, and you can navigate to it (after you put in your credentials) fine.

If you immediately follow through to the restart as it suggests to “join the Workgroup you must restart” bit, you will loose connection. Just don’t restart; and if you do, just press the NetworkID wizard > home Network, and don’t restart again.

I’ll look further into the issue with some network guru’s and see if they can lead me to a GPO or something.

We know it’s not firewall after you add let Port 445 TCP/UDP through (that killed all Windows sharing)

and it’s not the network browsing and Advanced Sharing settings.

Its’ some quirk to do with Workgroup Broadcast. Might want to check these services are running
Peer Networking Grouping
Peer Networking Identity Manager

I’ve got it working for now, I’ll try some other things next time round.

Luke


#26

Logging in to say that Windows pushed the update last night and now I’m dead in the water. WD cannot see my PC anymore. I just get the red circle of death. Have tried all the above suggestions with no luck. Is it time to retire the old girl? Anyone have any other suggestions?


#27

I tried this and immediately, y computer name showed up on WDTV. As Luke said, do not restart. For some reason, Windows will change the setting back to Public network. I wonder if there is a registry hack for this? Anyone want to try?

Jhon


#28

It seems strange that we are the only ones having this issue.
I’m using universal media server as a work around, but its not native folder sharing(which I prefer).

I just tried resetting my workgroup to home and not re-booting. This worked for me also. interesting.
I have not explored the master browser thing in Windows10. All pc’s in my home are Windows10. I wonder if the issue is that there is no master browser on my network at all?

Maybe the WdLive needs one? I also had the master browser issue with Windows 7. Windows 10 was fine until the last couple of updates, confirming everyones confirmations above.


#29

My first post here - ran into same 1703 update broke wdtv network shares. Thanks for all the sharing.
I tried all the same things I too usually try when windows updates, to “recover”, but no go for this update.
Found this thread and went through entirely but couldn’t un-grey network-id per IvanR8’s solution.
However, this might be b/c my win10 was already on a private (aka home) network mode already.
So out of curiosity I tried to just change my wrkgrp name slightly to wrkgrp2 and back to wrkgrp but NO restart per Imnau’s suggested articles above - this was averted by clicking “restart later” button choice.
What used to circle for hours on wdtv now circled just a few times and bingo I saw my shares again.
Even as a work around, this was pretty easy task to do and might have to for every reboot - who knows.
Just thought I’d share - I too have had my wdtv forever and it still prefer to keep it around and working.


#30

Same prob for me after the 1703 update. I can confirm Ivan’s steps work & I didn’t restart. My PC is on 24/7 anyway and rarely restart. Thanks guys.


#31

Since W10 1709 i had Problems to Connect WD with my PC .
Checked 4 times all Share Rules, User Login, everything, but nothing helped.

Solution (for me): Turn on all Option for SMBv1 in Windows Feature ( find it under Standard SW, left side Activate Windows Feature), Pop Up with many Options will appear, there you will find a bullet Point SMBv1 , in my case the last Option wasn´t set (SMB1 Server), activate + reboot.

Result: now WDTV Live react like every time before, was able to conncet to my Shared Folders under W10 1709 !

Microsoft disabled SMB V1 for unsafty reasons, but many old devices still need it. They will never update their own Firmware to SMB V2 oder V3.

Good luck to all !
Mr Peter


#32

Here is how to fix:

Steps:

Win+R (Run), type “optionalfeatures” and hit enter to bring up “Turn Windows features on or off”.
Scroll down to and expand “SMB 1.0/CIFS File Sharing Support” and check “SMB 1.0/CIFS Server” (Client was already checked for me) and hit OK.
Launch Powershell as administrator. (right click > run as admin)
Type “Set-SmbServerConfiguration -EnableSMB1Protocol $true” and hit enter.
Type “Y” to confirm
Reboot


#33

Solution for multiple network pcs all on the same workgroup that can no longer see each other. In the event of only one pc, add another pc to the same wireless or wired network.
Goto one of these pcs that was not the original workgroup pc and give it a new workgroup name. Then change all the other network pcs and other media to this new workgroup. Reshare all network drives.
I’m curious to hear if this simple solution works for anyone else and please share if you try it.


#34

he guys,

i’ve been updated my PC to W10 Pro b1709. Now I have the same problem. Because that Update, was an Upgrade (no New Installation) so thats State of play:

  • Windows Feature SMB1.0 is still on (all)
  • sc query lanmanworkstation is running
  • get-SMBServerConfiguration EnableSMB1Protocol is true

But, and this is what drives my crazy, WDTV is not seeing my SMB Files.

With the trick: Control Panel -> System -> Advanced System Settings -> Computername -> Network ID -> Private Network -> ok and don’t restart. This is only the 1 thing, where WDTV can see for a very short time the SMB Files.

Any idea? Did i miss something?


#35

Very easy - WDTV is S H I T without any support.
Dont buy WD product anymore.


#36

Same problem here. I had hoped these fixes turning on the smb1 and the powershell command would work…but no. I wish WD would help us out here. It seems they have abandoned us.


#37

the really know about that problem. the see that the internet is full of this problems.

But the don’t react. They didn’t talk what specific technical features are required to work for this player.


#38

I use 5 WDTV Live devices for streaming files to 5 locations in my house via home network. I trusted WD when I purchased these units to supply customer support, It’s irrelevant if this is a legacy item. A upgrade from WD is all that’s required to resolve this SMB issue. I also own several WD external and internal hard drives, I have trusted them and given them business they were always my first choice. medved is totally correct, if this is their response to their customers [return customers who keep them in business] a total boycott and consumer awareness is the best and most appropriate response. don’t give them any business.


#39

Windows 10 pro - 1709 - build 16299.214
2- wdtv live boxes stopped seeing shares…

Sometimes frustration makes you do crazy stuff…

Win+R (Run), type “optionalfeatures” and hit enter to bring up “Turn Windows features on or off”.
Turned anything to do with networking on… rebooted PC
Shares all popped up on the WDTV Live boxes…
No time to figure out which one fixed it, just very happy to be
watching my .iso movies again !!! :sunglasses:


#40

It was probably the “SMB1.0/CIFS File Sharing Support” that got the WDTV working again … since that’s all they support.

And SMB1.0 is now a Security Risk

https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/

I stopped using WDTV’s years ago … My Raspberry Pi 3’s have been patched/updated to support SMB 2 and SMB 3