WDTV & Windows 10 (Build1703)

I have managed to cure the error by making my router the master browser. A BT Hub 4 creates a workgroup called HOME as apposed to the windows default WORKGROUP. So all I had to do was change my windows 10 PC’s to the workgroup HOME, restart everything making sure the router was first up and voila!!! all working for now and it has survived several power cuts so its a robust solution.

How do I make my Verizon MI424WR router the master browser?


Unfortunately I have no idea. I read about making your router the master browser somewhere online and when I investigated my router I couldn’t find a method to configure it. It turned out It was already doing it by default I just needed to have all my devices on the same workgroup to allow the solution to work,


Looks like the May 9th includes updated code for SMB…I hope it resolves my issues. Wish I knew of a way to test the master browser status without having to install 1703. It the past I’d use BROWSTAT,EXE but that tool doesn’t work in Win10. Guess I could use WireShark.

2017-05 Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4019472)

Addressed additional issues with the Windows Shell, enterprise security, Datacenter Networking, storage networking, Internet Information Services, Active Directory, clustering, Windows Server, the client platform, and Internet Explorer.
Security updates to Windows COM, Windows SMB Server, Windows server, Internet Explorer, and Microsoft Edge.

Try the “lanscan.exe” that’s on this page, it was helpful to me;

I solved this problem as follows:
I shared the WDTV device by plugging in a USB memory stick.
WDTV is the master browser.
Sorry for the bad english

WDTV Live and WDTV Hub need SMBv1 enabled to be working. Microsoft is recommeding to disable SMBv1 due to the recent Wannacry ransomware. When SMBv1 is disabled on any Windows/NAS devices WDTV stops accessing Windows shares. Master Browser is a legacy protocol.

I had to switch to NFS instead of enabling SMBv1

I’m using Windows 1703 and still could access my WDTV. Try my solution here:


Did not work. Sorry Ivan. All I wish to do is add my support to Damien Vincent’s original post, saying that nothing, absolutely nothing, has been able to restore normal sharing after update 1703. I am very familiar with every normal setting that is required for sharing, but after 1703 none of the regular settings, the whole shebang of them, are able to restore sharing. All I’m able to do is cast to device and nothing else.

Nothing will make my WDTV read my pc. Just the constantly spinning arrow when network source is selected. And that is something I have ALWAYS been able to fix, many times. Funnily enough, usually occurring after Windows updates where sharing settings were negated/lost. Even if I was able to restore sharing, I’m fairly certain I would be unable to share a solution here as I have tried every single thing so far, so if sharing was restored, I bet I would not be able to identify the cause.

My feeling is that 1703 destroyed a necessary Windows service, and that would not be a first for an update to do that. I had that happen on an earlier pc, a few years ago. Even researching the services required for sharing leads to ambiguity (a lack of consistency), because the available information about the services required, even the names of the required services do not match those that are present on my standard 10.2 Windows build. Not good. I still have every faith in WDTV, but not in Windows and its updates. (I can’t even roll back in my case).

So far, Windows updates have cost me a redundant brand new Buffalo Linkstation and a previously fine WDTV. Several hundred pounds of hardware rendered useless.

All I can add is that my solution of using my router as the master browser is still working fine. Its a BT Hub 4.0 and is pre set to create a workgroup called HOME and be a master browser, so all I needed to do was switch my PC’s and WDTV’s to HOME as a workgroup rather than the default WORKGROUP as it all started working again. This was all discovered more by luck than judgement, any help from Microsoft even with a Brother that works at head office in Seattle!!!

1 Like


Your post is quite alarming because the other day I finally answered the nag screen to check my privacy settings to get this 1703, and my Win 10 has been completely shut down for a few days. But, I just turned it back on and watched in Win Update screen the update finish downloading and start preparing PC for update. So, I have turned off the PC. (I am using my Win 7 right now.)

Is there any way to prevent this update from getting installed; I looked in Win Update and there doesn’t appear to be.

I am unclear what this problem is:

Does 1703 cause non-sharing of ANY sharing of any devices, or just the PC-only with the WDTV? Everything was and still is originally shared via my Win 7.

Will this prevent my WD NAS from being shared to WDTV?

This is so darn confusing and frustrating.

To my knowledge, once you have started the update you have to finish, but re start and see what’s happening. As to your NAS? not sure if that will be affected or not, it depends on which device wins the master browser election and is calling the shots sharing wise.

I set my router to be Master Browser years ago and those MB issues with WDTV are history.

So does 1703 mess with the Master Browser conditions and cause WDTV to (erroneously) be MB again?

I’m thinking I will need to let update install and just cross my fingers that all will work as in the past. since my MB setting is from router and not PC.

I’d like to support IvanR8’s solution with one minor correction… DO NOT RESTART!

So something weird in the protocol stack is causing the Net Broadcast to close.

I figured out the the NetworkID wizard just asks the question so it can figure if you are a Domain or a WORKGROUP… and always starts from the default of . my computer is part of a busines…BLAH BLAH,

If you choose part of a home network…even if you are already part of MYWORK or MSHOME… it will change it to WORKGROUP, much like doing a network troubleshoot changes it to DHCP :frowning:

But what I did notice is that after you press that button, it shows up on the WDTV, and you can navigate to it (after you put in your credentials) fine.

If you immediately follow through to the restart as it suggests to “join the Workgroup you must restart” bit, you will loose connection. Just don’t restart; and if you do, just press the NetworkID wizard > home Network, and don’t restart again.

I’ll look further into the issue with some network guru’s and see if they can lead me to a GPO or something.

We know it’s not firewall after you add let Port 445 TCP/UDP through (that killed all Windows sharing)

and it’s not the network browsing and Advanced Sharing settings.

Its’ some quirk to do with Workgroup Broadcast. Might want to check these services are running
Peer Networking Grouping
Peer Networking Identity Manager

I’ve got it working for now, I’ll try some other things next time round.


1 Like

Logging in to say that Windows pushed the update last night and now I’m dead in the water. WD cannot see my PC anymore. I just get the red circle of death. Have tried all the above suggestions with no luck. Is it time to retire the old girl? Anyone have any other suggestions?

I tried this and immediately, y computer name showed up on WDTV. As Luke said, do not restart. For some reason, Windows will change the setting back to Public network. I wonder if there is a registry hack for this? Anyone want to try?


It seems strange that we are the only ones having this issue.
I’m using universal media server as a work around, but its not native folder sharing(which I prefer).

I just tried resetting my workgroup to home and not re-booting. This worked for me also. interesting.
I have not explored the master browser thing in Windows10. All pc’s in my home are Windows10. I wonder if the issue is that there is no master browser on my network at all?

Maybe the WdLive needs one? I also had the master browser issue with Windows 7. Windows 10 was fine until the last couple of updates, confirming everyones confirmations above.

My first post here - ran into same 1703 update broke wdtv network shares. Thanks for all the sharing.
I tried all the same things I too usually try when windows updates, to “recover”, but no go for this update.
Found this thread and went through entirely but couldn’t un-grey network-id per IvanR8’s solution.
However, this might be b/c my win10 was already on a private (aka home) network mode already.
So out of curiosity I tried to just change my wrkgrp name slightly to wrkgrp2 and back to wrkgrp but NO restart per Imnau’s suggested articles above - this was averted by clicking “restart later” button choice.
What used to circle for hours on wdtv now circled just a few times and bingo I saw my shares again.
Even as a work around, this was pretty easy task to do and might have to for every reboot - who knows.
Just thought I’d share - I too have had my wdtv forever and it still prefer to keep it around and working.

Same prob for me after the 1703 update. I can confirm Ivan’s steps work & I didn’t restart. My PC is on 24/7 anyway and rarely restart. Thanks guys.

Since W10 1709 i had Problems to Connect WD with my PC .
Checked 4 times all Share Rules, User Login, everything, but nothing helped.

Solution (for me): Turn on all Option for SMBv1 in Windows Feature ( find it under Standard SW, left side Activate Windows Feature), Pop Up with many Options will appear, there you will find a bullet Point SMBv1 , in my case the last Option wasn´t set (SMB1 Server), activate + reboot.

Result: now WDTV Live react like every time before, was able to conncet to my Shared Folders under W10 1709 !

Microsoft disabled SMB V1 for unsafty reasons, but many old devices still need it. They will never update their own Firmware to SMB V2 oder V3.

Good luck to all !
Mr Peter