Wdtv / Synology Nas / File Shares

I"m trying to set up my WDTV Live Streaming on a wired connection to my Synology DS212j NAS (through a Motorola Surfboard router/modem), but I can’t get the WDTV to find any file shares.  The WDTV sees content pushed by the NAS by way of DLNA media server, but shares seem to be invisible to it.  I want the NAS to appear in media library, with metadata.

When I try to get the WDTV to add a Windows share I get the spinning arrow indefinitely.  When trying a Linux share I sometimes get the IP address for the NAS (rather than its name), but if I select it I get an error message that it is not available. 

I have both WFS and Linux NFS file sharing services turned on in the NAS, and the NAS and WDTV seem to be on the same workgroup.  I have tried looking for shares with the DLNA server on and with it off without any difference.  I’ve tried setting the WDTV to connect to windows shares with and without user and password security set up on the NAS – no effect.  I have rebooted both devices several times.  No luck.

The WDTV is new – I am migrating from a WDTV Live with WDLXTV firmware, which was able to access the NAS without trouble.

So far I have not been able to find any guidance from searching the forums.  Very grateful in advance for your assistance.


Having the same problem. I have a Synology DS211j on a Netgear WNDR3700. The WDTVLive is new and connected  to my network wirelessly. I’ve attached a small USB external HD to it as well. While I can watch videos pushed by the media server on the Diskstation (it shows up as a Media Server), I can’t get it to appear in the WDTVLive Media Library. Tried most of the things you’ve tried. Interestingly, I have an older D-Link DNS-323 NAS on the network as well and it does show up under Network Shares\Windows Shares. Could probably transfer the TV Series to the DNS-323 (much slower than the DS211j though) or just put them on the WDTVLive USB hard drive, but that would sort of defeat one of the main reasons for having it (it’s attached to a small television in the kitchen so my wife can access her TV series there - has to work easily as a result). Seems like something needs to be enabled on the DS211j. If you (or someone else) is able to make any headway I’d be keen to know.


PS tried connecting a QNAP TS212 to the network and had the same issues with it as with the DS211j (worked as a media server but didn’t show up as a share)

Hi Larry – any luck solving this issue?  None yet on my end.  I don’t know whether to contact WDTV or Synology, but can’t accept that the two won’t work together better than this.  The WDTV has to work with NAS boxes.


Hi Dave,

Hadn’t done a lot more work on it as I copied most of the TV Series my wife watches to the USB HD attached to the WDTVLive and was spending my time trying to get the thumbnails to look the way I wanted (another story). Did some more fiddling today though and found that simply changing the workgroup name on my DS211j back to the default “Workgroup” (in the Synology Control Panel - File Sharing and Privileges under Win/Mac/NFS) made it visible under Network Shares\Windows Shares (my network has a different name but I had not used it on the WDTVLive). Now I can add folders on it to the Media Library (used my admin username and password to access all the folders). Same fix gave me access to files on a QNAP NAS. If the workgroup name on your NAS and the WDTV are different maybe that’s the problem…


Using a Synology DS110j works ok for me. Well, besides the bugs of the WDTV firmware that makes it reboot or when it stutters and stops from wifi being broken from a microwave.

WDTV FW:1.07.18

didn’t like the changes made in the .08 and above FW.

Running DSM 4.0-2228
Media Server 1.0-2259
workgroup name set as oemworkgroup
Services running WebDAV,Windows file Service
Packages Media Server

Have a user WDTV setup in users group, with read only  on Video,Photo,Music. Read/Write Public.
Application Privileges Audio Station,WebDAV

in Media Server app DMA Compatibility Device list button
Device: WDTVLive Profile: WD TV Live

On the WDTV

under say Videos

Select Content Source

Network Share /Windows Shares

NAS network name example DS110J

Login using the WDTV user name that has read only on the video folder.

That way when and if it does crash it’s not busy writing data to the NAS and mesing things up.

Only thing that happens when it crashes or reboots sometimes have to re-login into network share. But, I like it that way if I am going to spend all the time building media data for video files I don’t need the WDTV making new meta data that could be wrong or do what it did when connected via usb is copy a whole video file to wd_tv folder for its own libary meta data.

Other thing is the Stitic IP for both devices.

So, if your router supports reservation by mac address makes easier.

example of the Synology is alway at

and the WDTV is always at

Thanks for the suggestions.  My entire home network is still set to the default workgroup name, “WORKGROUP”, including the NAS and WDTV, and my NAS settings are generally the same as yours Captylor.  Still no dice.  The WDTV sees my PC if file sharing is turned on, but the DS212j does not appear in the list of Windows Shares.  I also tried changing the workgroup name to something different in both NAS and WDTV without success. 

I bought the new WDTV to replace the old one primarily because of the automatic metadata, but without file sharing I’m getting nowhere.  Not sure what else to check here.

See if this tutorial for troubleshooting helps:


Hi there, i also have Synology DS212j and i don’t have any problem seeing shares from wdtvlive. Wdtvlive finds it through windows shares and never had any problem. Your problem must be a network setting.

I started down the road of the excellent tutorial linked by TonyPH (thanks a million Tony) and ran into problems right away getting my workgroup to show up in Net View.  That lead me to fiddle with firewall settings on both my PC and my NAS.  I think my problem turned out to be firewall-related.

The NAS firewall was explicitly supposed to be leaving open all Windows Sharing ports (137, etc) but when I disabled the firewall suddenly the WDTV showed the Diskstation among its shared locations.  It’s now compiling my media library. 

I’m very happy but feeling worried that all will be lost the next time any of my components (modem, router, NAS, WDTV, PC) are power-cycled.  If that happens I’ll keep troubleshooting and keep this thread posted.  In the meantime I think I’m good to go – thanks to you guys for your help.


I believe the key was in captylor note…

“Have a user WDTV setup in users group, with read only  on Video,Photo,Music. Read/Write Public”

I don’t believe I read you stating that you created a user “WDTV” or whatever you’ve named your WDTV box in DSM.  You need to create a user for the WDTV box in DSM and allow it privileges before DSM will allow it to access your files.

And, put the firewall back to the way it was as you might be exposing your NAS to unauthorized access.

Yes that is right I made a user account in the Synology users list to login with the WDTV.

For two reasons 1. to be able to tell what the wdtv is accessing and to limit what damage it can do to the files.
2. For the odd times when it is failing to login with an anonymous account by default. Even after I have given it the login to use. Then it comes back sometimes with the anonymous login failed.

Then good at that point I know that the synology system has expired the login and needs a re authenticate on that.

For the reason of it being read only… Well, after looking and reading post after post on here about how the WDTV was just compiling media library and happened to crash and corrupt every file on the drive.  More of safe than sorry. Besides I like the outside tools to do media scraping since it is easier to fix than having to fix a bad scrape of my media files.