WDTV stops playing via wireless connection

Hi there!

I was wondering if someone can enlighten me as to resolve this issue. Just recently my WDTV will start to play a movie, and then it will stop! It will play about 4 minutes of it and then the playback just stops. :confounded:

I have done a reset on the unit, done a reset on my WDTV Live, but the issue is still there. The unusual thing is that I can play episodes of The Simpsons with no issues. It’s just on movies. Any ideas?

I’m streaming them wirelessly to my WDTV Live via a Belkin N300 router. 

Thanks for any help.:smiley:




Make sure you have the latest firmware installed as this can resolve this kind of issues. Also try a factory restore on the media player from the system menu.

Hi HDKnows!

Thanks for your reply. 

The latest firmware is installed and I did a factory restore on the media player, but this hasn’t resolve the issue. Any other ideas? The files are .avi format, but I used to be able to play these with no problem. 



Are you saying that you have actual avi movies that used to play and now don’t or just that new avi files don’t play.

They are avi I have not played before. But in saying that, there was one movie that I have played previously with no problem and that stopped after several minutes too.

I did a Quick Factory reset, but still the same problem. Any theories aside from maybe corrupt .avi files?

TIA for any ideas/theories.

If they are new to you then it may just be that they are encoded differently, an avi file is just a container and it mat be that the internal codecs have changed. Are they internet downloads?

Hi guys!

This is getting more bizarre! Today I did a full factory reset, then got a video online in mp4 format. Went to watch it this evening and it up just stopped playing after 2 minutes!

I’m about to pull he plug in my WD Live hard drive and go all flintstoney and just watch movies via flash drives. Pity because I find it convenient streaming movies wirelessly.

If anyone has any ideas as to how I can fix this major bug I will be so happy,

Thanks guys for any advice/pointers/theories. Maybe there is something being screwed up at the router end? I have a Belkin N300 router that the WD Live is networked into via Ethernet cable

I’ve had EXACTLY the same issue, ever SINCE upgrading to the latest firmware.

The issue is DUE to the latest firmware.

I used to be able to stream via DLNA, using Twonky Beam Android apps, on my mobile phone or tablet.

Since upgrading to the latest firmware, the box frequently drops its connection to the wireless network.

It’s less likely to drop the connection if I stream a file under 30 minutes in length; but that’s not to say it still won’t drop the connection.

I’ve given-up on being able to stream full movies now.

I continuously have to manually connect to the wireless network, by accessing:


Network Settings;

Previously Connected Wireless Network;

Connect now.

I then have to cross my fingers that it’ll last for at least the duration of a YouTube video I may want to stream from my tablet.

Yes, I have carried out a Factory Reset.

The unit is currently unuseable, for the purpose I used it the most.


I’ve rolled-back to the earlier firmware v.1.16.13 and the problem has gone.

Wish I’d done this a week ago. Well, I wish I’d never upgraded to the latest firmware, but I should have rolled-back sooner.

1 Like

Hey Justin!

The roll back fixed it!

Thanks heaps!