WDTV stopped detecting HDD

I have a WD TV Live Streaming Media Player and I have a WD My Book Essentials external USB 3.0 HDD 3TB ( i been using this HDD for about 2 yrs. with no issues)
everything was working great last night watched some movies off my HDD then turned everything off, this morning when i turned it back on it wont detect my HDD anymore my laptop will but not the WD TV but it will detect a usb flash drive ive tried downgrading the firmware to many different versions and even did a factory reset on my WDTV and i even got another Seagate External 3.0 HDD 3TB and tried that wont detect that one either both are formatted NTFS
i checked these forums for a fix but nothing all issues seemed to be fixed by downgrading firmware and nobody seemed to have the same problem of it working then just stop all others seemed to have issues either when they bought it, it just never detected the HDD or after firmware upgrade 
i didnt upgrade the firmware while i was sleeping


I have exactly same problem since updating to 1.14.09. Frankly speaking I had always a bit of trouble with my WD My Book Essential 3TB, USB 3.0 (not able to wakeup or freezing caused by infamous aggressive spin-down) especially when plugged into rear USB, but now WD SMP only says connecting USB storage and after a couple of seconds nothing more happens, regardless which USB port I’m going to use.

As the opposite Seagate FreeAgent GoFlex 2TB USB 3.0 works flawlessly (as always did). I began to be tired and disappointed with whole WD brand and considering to shift it with Mede8er MED600X3D.

What I always wanted from this device is just seamlessly play local content since I don’t care much about streaming services and I’ve still my NAS adventure ahead.

Conclusion, while two WD product should work/communicate together with no issue, every firmware update makes it worse.

It’s not a firmware issue but as been mentioned several times already, there’s a problem with some USB3 drives attached to the back port. They work fine attached to the front port and there are quite a lot of models that don’t have any issues with either port.

I’m sorry but that’s not true. I have 3 x 3TB Seagate Expansion drives.

The 2 of them that I have used on the SMP before used to work but no longer work since update 1.13.8. I have only ever used the front USB port. I tried the drive that I have not used with the SMP before and find that it works.

I wonder if the SMP is doing something to the drives that it subsequently doesn’t like.

There is also nothing wrong with any of the drives. They all work perfectly with any PC or Laptop that I have connected them to.

Doesn’t change the fact that one of the three USB3 drives I’ve tested runs perfectly fine on any port on 1.14.09 so it doesn’t look like it’s the firmware either. Unless > 2 TB is the determining factor for this issue.

I must admit that I also don’t agree with your statement. I’m pretty familiar with mentioned rear USB issue (another reason to finally move to something else than WD since mentioned issue is known about a year or so, widely discussed and completely ignored by WD. Btw I’m going to give my unit back to the shop since it doesn’t work as advertised).

As stated in my post WD My Book Essential worked with some hiccup before firmware update, after doesn’t work at all - not recognized by player either in rear or front port. In opposite Seagate works flawlessly plugged to the both of them. Considered the above it is hard for other conclusions than firmware issue (on the top of hardware problems).

It is shame because I really liked many other features but I’m just tired with poor basic functionality and lousy support from WD.