WDTV No Longer Shows in Network

Well, im stumped. Changed to a new Router, Linksys WRT120. 

The Network was working fine, the WDTV c9ould see my Win7 DLNA shares. Was too slow for WIFI even with N sharing heavy files and thats where the troubles began.

Moved it through to the PC as always to connect it to Ethernet and copy the files over manually.

This time instead of showing up as a device it showed up as a Media Player and let me play ther files but not access the HDD.

Now it just doesnt show up AT ALL,m not in Ntework Places, not in the Network Map, nowhere.

Not able to access the HD to copy anything to it…just really unhappy, its on the latest firmware, its just really poor.

I have seven other devices connected to the network and everything works just fine, but the WDTV HUb since it was recognised as a media player of sorts just cannot be accessed as an external disk anymore.

Ive searchged for hours, tried everything. Router settings are fine, same as I always have them, im not running any additional software and I really dont understand how this happened or why, or indeed how it can be designed allowing this to happen after something as simple as a router upgrade.

Dont even know how to proceed, decive is basically useless ATM.

Anyone have any solution to this?

Thanks.

If you’ve changed routers, and you’re using Vista or Win 7, then your PC probably created a NEW NETWORK PROFILE.

Open the Network and Sharing Center and make sure that the profile is set to a HOME NETWORK, and then verify that your Sharing Parameters are correct.

scrape.png

This happened to me twice…  when replacing my FiOS router… twice.  :)

Note how MINE says “NETWORK 4.”   It used to say “NETWORK 1.”   So it’s changed profiles three times since then.  I don’t remember what caused the first change.

I already merged the old profiles back into a single profile called NETWORK.

Really dont get it, its like plug without the play now, I plug the **bleep** thing into the Network and it just doesnt show up.

Driving me nuts. Thanks for the suggestion though. Any more would be appreciated.

PS, this isnt a Windows 7 issue as I have a Vista Laptop and an XP Laptop as well as 2 7 machines on the network and it wont show as a disk in ANY of them.

Also tried mapping to the IP, error is device wont accept the connection.

It shows as a Media Device, I can access the Web Login from there, all works fine but in the end its totally useless as I cant access the HDD at all to copy files across to it.

Ive tried disabling UPnP in the Router, Router Firewall is off, theres nothing else set that has any relevance. It just refuses to be seen as a Disk Drive now. Files cant be copied via USB cable to the PC, its basically useless after a Router Change, pretty much struggling to grasp how it can be designed with such a glaring flaw.

Do WD support these forums or is this just User assited support?

You make this statement which is unclear-

Moved it through to the PC as always to connect it to Ethernet and copy the files over manually

Did you mean you connected the WDTV Hub directly to your PC via ethernet cable? Or do you mean that you connected the WDTV Hub via ethernet cable to a switch and/or router on your network?

This is a user assisted forum, if you wish to official WD support,  you will need to contact them.

To Contact WD for Technical Support
http://support.wdc.com/contact/index.asp?lang=en

To the router. Basically the PCs are in the study with the Router. The media box I have in another room and I simple take it and connect it to the router via Ethernet to copy files.

Used to work perfectly, until I upgraded the Router, one Linksys to another Linksys, and since then its now decided to become recognised as a Media Device and can no longer be accessed as an HDD.

So now I can log into its web interface and that of course had no way to allow me to access the HDD either so im now stuck with a box I cant copy anything to.

Yes, I was just trying that, however as I forgot the password to the forum, and the support takes the same username and pass I cant get support.

I tried requesting a new password and the mail never arrives, its the right mail as if I try register for support it tells me I have registered already. All pretty surreal really, a simple router upgrade and all this mess from it, cant really grasp how that can be. At the very least if this was possible they should have put an option in the web interface that would let users get to the drive itself for copying files.

See if this tutorial for troubleshooting helps:

http://community.wdc.com/t5/Networking/Troubleshooting-Windows-File-Sharing/m-p/92642#U92642

Thanks for the link, but its the same.

The only two computers that show are my main machines. The Media Server doesnt show at all with nbtstat, I can access it via HTTP, I can ping it, however it wont show at all as a device, has no WORKGROUP information or anything else. Its acting like something changes in its internal settings and now it just refuses to allow itself to be seen as anything else.

Ironically shares work, If I connect the wifi card to the box I can connect to network and access the files from the PC just fine. Cant get my head around it, the shares id understand not working but how it can not even show itself as a storage device on the network.

Its not like we are talking some obscure router change, both Routers are Linksys, major brand routers, if this is what happens on a standard upgrade, I have no idea what the devs were thinking.

Ive been working on this since yesterday morning and made no progress what so ever on it.

Is there a way to restore the settings of this **bleep** thing WITHOUT wiping out all the files I have stored on it at this time?

I want to reset the firmware back to standard, but ONLY the firmware. Im pretty much convinced that the box has gone screwy in its settings because the network is working perfectly in every test and check, the device just refuses to be seen for what it is.

Are you running both Wireless and Wired network connections on your PC at the same time? This won’t work.

No, I removed the wireless when I brought it through to connect it via cable.

The other possibility is that when I connected it via wireless that is what caused something to change inside it and the box itself caused the problem. Before I never used wireless, just manually copied the files but when I upgraded to an N router, I also got an N wifi card for the Box.

Since then, any attempts to connect it via LAN cable to the router and access the HDD from PC have ended in total failure.

As I said, it will PING fine, the Webhub works fine, I can even take it and connect it wireless and the DLNA shares work fine.

The one thing I critically need, the ability to access the HDD from PC via LAN, no longer workjs because the box seems to have decided its a media device now and no longer wants to act as an HDD.

To Clarify, while the network is wireless enabled, the only things that use it are the Media box when its NOT connected to the router and is in the other room with the TV, and the laptops when I need. My two main boxes and cable connect into the Router.

You seemed to have messed up your network. It is unlikely to be the WDTV from what you describe.

Try this procedure-

  1. On all PC’s, turn off the Wireless connection. Also do this on any  other devices you have.

  2. Shutdown all computers and devices on your network. This includes routers/switches/bridges or anything else that is a network connected device.

  3. Start powering up your network devices in this sequence (leave a few seconds between each until you are sure the device is fully up and running)-

a) Router

b) Switches/Bridges

c) PC (only power up your main one)

d) NAS devices

e) WDTV

f) Wait a few minutes for the network  broadcasts to stabilize.

What happens after this sequence?

Thanks for the help, appreciated, but I solved the problem with brute force, couldnt bear any more messing around.

It was the HDTV box BTW, I nuked the settings back to their originals, and it plugged and played as normal again. My guess is that when I upgraded the firmware something got messed up, it did fail first time and then second time worked. I suppose one of the settings which make it broadcast its file share server status got nuked.

Anyway, its solved now so if it happens to anyone else, thats really the only solution I could fine and I believe quicker and less painless than taking the long way I did!

:slight_smile:

Thanks everyone.

When you say that you nuked the settings back to the orginals do you mean that you reset to to factory defaults in the internal menu?

Correct, right down to the original Firmware, bit of a pain but it worked and after two days of headaches that was really the most important thing.

Im guessing some setting got chewed up, maybe during a firmware upgrade which I did right around the same time. Very irritating issue.

I had the exact same issue.  Rolling back the drivers to version 2.06.10 from

http://wdc.custhelp.com/app/answers/detail/a_id/5860/~/how-to-roll-back-the-firmware-on-a-wd-tv-live-hub-media-center

fixed the issue.  I did not have to reset any settings on my WD drive.  This was a two day frustrating event, one would think that WD would spend some more time making sure the firmware was good before rolling it out.