WDTV live won't start

Hello. I’ve just received a new unit from Amazon, and it doesn’t seem to work. I’ve plugged it in to 2 different tvs with 3 different HDMI cables, and I get the same results every time.  The unit turns on, I see a WD boot screen for a few seconds, and then the tv reports its receiving no signal.  The unit is still on, with a solid white light on the front, and it’s not crashed because I can hold the power button on the remot and it will turn off and back on.

I would try to use RCA cables to see if there’s some HDMI setting I have to enable, but unfortunantely mine didn’t come with those cables for some reason. So I can only use HDMI to connect it.  I have tried resetting to factory defaults with a paperclip, but it made no difference.

Firmware - unknown, as i can’t start it

I guess I should add, it’s model WDBHG70000NBK-01…

Sounds like your device might be DOA but… try a power reset.  Remove power adapter plug for a few seconds and reattach.  Connecting with HDMI should not be a problem.  I have for some strange reason notcied my WDTV Live Hub performing similar to your WDTV Live recently.  Logo appears then “No Signal” message.  Sometimes if I wait it will come back.  If your’s still doesn’t operate correctly I’d send it back for a replacement.

rahdo wrote:

I would try to use RCA cables to see if there’s some HDMI setting I have to enable, but unfortunantely mine didn’t come with those cables for some reason. 

That’s odd.  If it didn’t come with the cables, I would suspect it is an “Open Box” item, not new…  and it might have been returned for that very reason, without the original purchaser telling Amazon that it wasn’t functional.

Well damnit. My wife picked this up while she was vising in the states, and has now brought it back to Malta. So it’ll cost almost as much as the retail value of the box to ship it back to Amazon. Gee-reat! :frowning:

is there any way I can get a WD 3.5mm to RCA cable that’s supposed t come with it, to see if that can fix it?

You can call WD Tech Support, and see if they’ll give you one gratis.   But they might charge a few bucks for it.

If this was purchased in the US, then it’s probably out-of-the-box configured for NTSC TVs, whereas Malta requires PAL. 

This should NOT matter for HDMI connections, but if you go with the 3.5mm plug, it WILL need to be changed to PAL mode via the reset button (you hold it for 10 seconds after it’s booted up to change the modes.)

It might be worth a try just to see if that might also change the HDMI config somehow.

RCA output jacks?? Come to think of it… what model WDTV Live do you have? Is it a Hub?

It’s the one shown here:  http://www.amazon.com/Live-Media-Player-Wi-fi-1080p/dp/B005KOZNBW

Yea? So where do you want to plug in RCA cables since there is only a HDMI output on your Live-Media Player-WiFi?  And why would you expect that unit to have come with RCA cables to begin with?

Back to your original issue… I’m assuming you have enabled the proper input source on your TV?  HDMI 1 or 2, etc depending on what connection you make to your TV.  Also, as I said earlier, almost exactly the same thing happens on my Live Hub.  No Signal message…but if I wait a bit (no more than a minute typically) my WD finally begins outputting correctly.  How long do you wait to see if your unit is working?

SlimyPizza wrote:

Yea? So where do you want to plug in RCA cables since there is only a HDMI output on your Live-Media Player-WiFi? 

Slimy, the Live SMP does have Composite output as well.

Ah!!  My bad… I was expecting three composite connections.  I’ve only used HDMI.  Never messed with the A/V jack.  Apologies…

No prob!  I’d rather ignore the RCA too, but I’m desperate now… :frowning:

Here’s a *BLIND* way of selecting HDMI output (if your device is set to Composite)

do this *SLOWLY* with the HDMI cable attached

  1. Press “Setup” on your remote

  2. Press “Ok” on your remote 5 Times

  3. Press “Right Arrow” on your remote

  4. Press “Ok” on your remote

Fingers X you will get a picture via HDMI

Thanks Joey, tried but no luck.  So I just spent 30 minutes on the line with WD, and the confirmed that the serial number of the unit was registered to someone else and the warantee expired 6 months ago.  So even though I was sold a new unit, Amazon seems to have sent me a refurbished one that doesn’t work.  Now begins the haggling with them… :frowning:

Yep, good luck… :slight_smile:


While you wait and waste time from Amazon, just order a new one from Newegg, and just try to get a full refund from Amazon – to heck with getting an exchange!  I buy lots of electronic stuff from them and easier to work with on refunds etc. than Amazon which sells everything from soup to nutz. 

Newegg ships from the LA area.


Well, the end result was I called WDTV to ask about getting RCA cables, and they looked up the unit’s serial number and discovered it was registered to someone else in 2013. So I called up Amazon and told them they sold me defective used unit as new, and they refunded me the full price, and waived the need for me to ship it back to them (which would have been very expensive from Malta). Newegg’s international shipping will probably be a bit too high, but I’ll look for one over here in Europe. Turns out I can buy one at Scanmalta 100 euros… a bit more than I had to pay originally, but otoh if something goes wrong I can return it to the store!  :)