WDTV Live wont play media its played 100 times before till reset or reboot .. Help please

Hey guys,

So I have a WDTV Live and its been AWESOME till recently when it started acting crazy!

It randomly STOPS playing media that it has played a MILLION times before (seriously, they’re toddler cartoons for my 2 and 3 year olds so… YES, a million times… you got kids? You KNOW what Im talking about! LOL!)

I have it connected via USB cable to a WD Passport drive. Ive had this setup for 2 or more years without any problems. Recently, it seems randomly, it will stop playing all media thats its played in the past until I pull out the power cord or chose “reset to factory defaults” from the setting menu.

At first I thought it was some new content I added to the drive, so I deleted it but its still randomly not playing the old files. I get the blue spinning circle… nothing else. A few times (not always) I get the “cant play this media type refer to manual for a list of  supported media” .  It wont even play the small preview you usually get when you just highlight the file.

I havent updated firmware in a few months (the problem first appeared 6 or 7 days ago) so I tried updating the firmware to which I get the message that its up to date; so thats not it. Tried resetting to factory defaults; that gets the unit to work till the next time. I tried pulling the power cord and plugging it in (I forget if that works or not, think it DID) pressing the reset button on the side of the unit with a pin worked (unitl the next time). Tried ejecting the drive and replugging it in,tried the other usb port on the side… problem persists…

My kids’ media is all 3 or 4 minute songs or 10 or 15 minute cartoons. having to reset the unit after 6 or 7 minutes ( or 15 minutes) is driving me insane because THEYRE going nuts… “I want Bupple Guppies, I want Bubble Guppies… Give me BUBBLE GUPPIES”…


Things I havent tried yet… seeing if this problem occurs when streaming the media from my PC at other end of the house (I can easily put the media there) if it does, its the WDTV. If it doesnt, maybe its the drive??? I can always plug in a USB thumbnail drive with media on it too…

The problem doesnt seem isolated to any one media file… MOST of these files are in AVI format.


If you have a flash drive try adding some of these avi files on to it and then see if they play OK.

I am also having the same problem with my WDTV Live Plus. Somebody please help us with a solution. Thanks.