WDTV Live Won't Boot: Keeps Restarting

I have a WDTV Live media player that has worked pretty well for a number of years. My only issue is that sometimes boot up will have it display the opening screen for about 30 seconds, then it would go black and start again. On its second try, instead of going black, the “Connecting network…” message would appear and a few seconds later, all would be well.

A few weeks back, things changed. After the “Connecting network…” appeared for a little longer than usual, it went black and rebooted again. It now repeats this over and over again, all the time with its white light on.

I tried placing a firmware version on a USB drive and starting it with the drive in, but nothing different happened. This was not surprising, since for doing a firmware change this way, the unit would have to completely reboot and give me an option to install the new firmware.

Is there a way to force this to try to boot off of a USB drive?

Hi @calvin_hc,

Thanks for reporting the issue.

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for best assistance and troubleshooting:

Thanks for the suggestion. I have now filed a ticket. I hadn’t origionally as most tech companies “support” generally consists of suggesting posting in forums, especially for older products.

One word of advice to pass on to the keepers of the support ticket website: rethink making “operating system” on the form mandatory, or at least add a “N/A” choice in the pull-down list. It certainly does not apply for this product.

I had the same rebooting problem which started around 3 weeks ago.

I did a factory reset and it seems fine now. After the factory reset, the weather app is missing, so I suspect it was the weather app causing the initial issue.

In order to do a factory reset, I disconnected my internet (I just unplugged my modem), as without an internet connection, the box still worked without the rebooting issue.

I suspect this is a global issue with these boxes as there’s another topic about this - the most recent comment on this page was posted a couple of weeks ago, which may be a better solution for you rather than factory reset - https://community.wd.com/t/wd-tv-live-suddenly-rebooting-when-network-cable-inserted/204662/6

I can also confirm success in restoring sanity to my WD TV SMP Gen 3 boxes using the described procedure (see WDTV2020’s link to another thread) of removing the CAT5 network cable, and when the device boots up (might take a couple of restart cycles), go to Setup and do the “Reset All Online Service Accounts”. Then when all is stable, reconnect the RJ45 cable. The restart loop problem started for me on Jan. 30th. I found several discussion threads on a “reddit.com” WDTV forum where a dozen or so users chimed-in during the following week. Over the span of two or three days, several expert users identified an AccuWeather link problem and possible solutions.

I don’t know how the service account reset option is presented on other models, but on my 3 WD TV Live SMP (Gen 3) boxes , the steps are “Setup” > “System” > scroll to and click on “Device Reset” > click on “Reset All Online Service Accounts”. Select “Yes” for the confirmation “Are you sure you want to reset……”. I no longer use any of the internet-based “Services” on my WD TV’s, so there were no further issues for me.

The WD TV Live SMP Gen 3 has been the best media player that I have found for our family’s purposes of watching archived family home video and other archived videos. I bought 8 of the Gen 3’s since it was introduced, gifting most of them to my family members located in the US and overseas.

1 Like