WDTV Live + Windows 7 "Invalid Username and Password. Please Try Again Later"

Hey everyone,

I ran into this problem when I reformatted my computer & re-installed Windows 7 on it. Whenever I’d try to access my Network Shares, the WDTV Live would tell me “Invalid Username and Password. Please Try Again Later”. Frustrated me to no end lol! But I came across this in a forum on the interwebs and I thought I’d share it with everyone.

If you are getting this message and you installed the Microsoft Live Essentials, uninstall Windows Live ID Assistant. For whatever reason, this is what is causing the confusion between Win7 and the WDTV Live. After uninstalling Live ID Assistant, restart your computer. When your computer boots back up, right click on the folder you want to share, go to Share With and select Specific People… Then a window pops up. If “everyone” isnt listed as the people to share it with, click on the drop down menu, select “everyone” and click the add button, then click the share button. After it finishes sharing the folder, you should have access to your Network Shares from the WDTV Live. Repeat for any and all media folders you’d like to share w/ the WDTV Live!

That’s It! Took me the better part of 2 days to get this working! Enjoy!

Thank you so much. This only started yesterday and it has been driving me mad! I wouldn’t have had a clue if i hadn’t of read your post :slight_smile:

Good one

I spent a few days mucking around with both Network Shares and Media Players as well as Firmware, Homegroups, Shares and Security etc and my WDLIVETV kept saying “Invalid Username and Password. Please try again later” on my Windows 7 desktop, while my old XP laptop worked great.

I was not expecting this to work as I could not see the connection, but out of pure desperation, I un-installed Live Sign-in Assistant, and to my big surprise it all worked. Now my WDTV Live (firmware 1.02.21) connects to my Network Share automatically.

You still have to ensure on the shares that “Everyone” can read and Password Protection set so that people without a user account can access folder with everyone.  I wonder if I re-install Live Sign-in Assistant will it now work i.e. the order of install important.

Otherwise there is an incompatibility problem between Microsoft and WD. Not sure who is responsible to fix it.

Other device manufacturers are having the same issue with the Sign-in Assistant.   It’s bugging more than just WD…  But, Microsoft is the Big Gorilla.   “Live” is their future.  Doubtful they’ll change that…

Excellent… I lived the same problem… had lost few days on it… Now it works after applying your solution.

It was THE ONLY solution that solved the problem… Now I can surf my computers through WD TV Live… (Shared disks and files) without any problem…

Thank you so much…

I am experiencing this issue, but I do not have an entry for Windows Live ID Sign-In Assistant in Add/Remove programs on Windows 7.  But I do have Windows Live Sync Beta installed.

My take is that since I can still browse my file shares from other computers (even through Hamachi), this is an issue with the way the WDTV Live manages authentication.

I will report back after removing Live Sync Beta.

UPDATE:  Removing Live Sync Beta did not correct the issue.  I had WIndows Movie Maker installed as part of the Live Essentials package for quite a while and the WDTV worked fine.  Next step is to remove the whole **bleep** package.

Actually, the only way you can fix things is to roll back to before the Live sync was installed – try a restore before that period.

MS really screwed the pooch on this one.

Unfortunately I don’t have a restore point from that long ago.  But I did finally find the Windows Live Sign In Assistant as a running Service.  Disabling the service and restarting does not fix the WDTV’s login issue.

But I don’t agree that this is a Microsoft issue.  The WDTV Live has many flaws, and this is another that needs to be addressed with new firmware.  I can still connect to my windows 7 file share from my mac.  I can connect from other windows machines on the network.  Only the WDTV has problems connecting.  It’s a very problematic device.

It’s not just WDTV that has the issue.   Microsoft changed the authentication mechanism for network shares as part of the Live structure.  It’s affected Apple products, Linux servers, Syabas, and others.

It’s impossible to point a finger.   It IS MICROSOFT’S stuff, so if they want to change it, they can.   I don’t think they claim that their sharing components are fully SMB / CIFS compliant…

Search with google the phrase > “sign-in assistant” broken shares < and you’ll get thousands of hits, not just WDTV…

I’ve given up on this.  Regardless if Microsoft is at fault, the onus is on WD to fix the issue with their player.

I’m trying to get the Media Servers feature to work.  WMP has never pulled all of my video files into the library for whatever stupid reason.  So I’m now relying on PlayOn (which I purchased a while back for Netflix support).

Anyone have any other suggestions for free media server software since WMP obviously ■■■■■?

So I guess I lied.  I didn’t give up.  I uninstalled Windows Live Essentials Beta completely – not just Live Sync, but also Movie Maker.  I knew when it asked me to restart that it was probably going to work, and it did.  I can now connect to my file share again.

It still puzzles me though.  Hopefully when Microsoft releases Live Sync officially beyond beta (because it actually is a useful tool) that it won’t cause these issues.  But if so, I hope WD is aware and has a fix ready.

These CONTINUOUS issues keep popping up REPEATEDLY in Microsoft’s TechNet forums.   Microsoft has been remarkably quiet about it.

Here’s several threads:




I did some further digging on this.

I ran Packet Captures on my Win 7 Virtual machine before and after installing Windows Live.

Of course, everything ran fine until the Live Sign-in Assistant was installed.

Now I know a little more about what the issue is:

When it’s installed, the WD DOES Log In successfully.  

However, when the WD asks the server to “Enumerate” the shares (basically, list all the shares that the account has access to, the server immediately responds with PERMISSION DENIED.

The Windows Box should DENY LOGIN if it’s in fact, not allowed.   But it’s not.  It’s allowing the log-in, but denying the request to list shares.

That’s AFTER Sign-in assistant is installed.

BEFORE it’s installed, it does, of course, list the valid shares.  

So, it comes down to two scenarios:

Either the WDTV is issuing an INCORRECT Enumeration request (which is processed ANYWAY if SIA isn’t installed), OR SIA introduces a bug.

We’ll have to wait and see!  The issue has been around for almost a year.

Nice work there.  Live Essentials is still in beta, correct?  Hopefully Microsoft will address this issue before they release their final product (notice how I’ve switched stances and I’m on the blame microsoft bandwagon now).

By the way, I found a good Sync tool to replace Live Sync – called Syncplicity.  It’s like Dropbox, but allows you to sync any folder without the use of symlinks.  It only syncs 2 computers though in the free version.

Live Essentials “Wave 4” is in beta.  Live and its components in various versions have been around a while.   It looks like these issues began with Sign-In assistant 1.4, and is spreading to other components like Office Live Add-ins.

Thank you so much for posting!  I was so excited when I received my wireless USB and then so devastated when it wouldn’t work!

Cleared all Windows Live from my laptop and wireless usb on media live is working perfectly.

Thanks again.


Everything was working fine when I first setup My WDTV live … I could stream, view my network shares and see all my network. Then one day when I tied to access my network shares I got  “Invalid Username and Password”

I thought one of the Windows 7 securty updates may have changed some log in or security settings but every thing looked the same. I ran through the video tutorials posted by others that had the same issues but that didn’t work. then I notices something posted about Microsoft Live Essentials, uninstall Windows Live ID Assistant and all is now good.

Thanks heeps, flacster

Well another Windows 7 update has broken my connection between my WD Live and my Windows 7 PC. This time I can’t find the Live Assistant Add-In listed as a program to uninstall. I will keep plugging away to see what else I can uninstall in order to connect to the PC. Such a huge pain in the neck. Perhaps this should be a priority for the developers to fix. Is it addressable? I know it is Microsoft changing the rules but is there a path forward?

I noticde two new programs: Windows Live Mesh and Windows Live Essentials 2011. Could the Live Sign-in Assistant be lurking in one of these two programs?

Live Mesh I believe is their new sync tool.  So it’s quite likely that the sign-in assistant is there.  You’re going to find the sign-in assistant with any of the Windows Live apps that must log in to your Live account.  It’s actually pretty nice if it didn’t break the WDTV Live because it keeps you signed in on the web.

The “Windows Live Sign-in Assistant” or “Windows Live Sign-On Assistant”  will be listed in Services (start > run > services.msc).  Disabling the service does not help.  You’ll have to remove Windows Live Essentials completely to get rid of it.

I realize this is thinking outside of the box but it’s at least worth considering for those folks to whom the Windows Live thingees are important – one alternative is getting an NAS.

Nearly all NAS units run Linux and thus will be immune to any Windows shenanigans.  They also offer a ton more advantages (like much lower power consumption than a PC, other media services, much larger capacities, etc.).  My NAS is ALWAYS reliable, always seen by my Live units (and my PCs) with no issues.  The total cost of the unit, including two 2TB drives, was less than $400 (you can shop around and find prices all over the board).  That’s a small price to pay for 4TB of online, reliable storage.