WDTV Live - unable to copy files across network to USB thumb drive

I have just bought a WDTV Live.

Everything is working great except…

I cannot copy files from my PC to the USB thumb drive plugged into the WDTV.

It shows an error on the PC -  “Network Error - there is a problem accessing \Wdtvlive\store_n_go”

(The thumb drive is an 8GB Verbatim Store N Go)

It happens every time.

I can view the files on the drive from the PC. I can also delete files, and play files from the PC to my TV via the WDTV.

I can also play files from the WDTV thumb drive onto my PC using Windows Media Player.

I’m using WiFi, but have verified that same error occurs when using a direct wired Cat5 connection.

The PC runs Windows 7 (Home Premium).

The WDTV has been upgraded to the latest firmware.

Any ideas on how to fix this?


You can try mapping the USB drive

also test with a different computer

1 Like

Thanks for the reply.
I’ve now tried both your suggestions with odd results.

Mapping the share to a drive letter did allow me to successfully copy a file onto the WDTV’s local USB storage - but only once.

The next time I tried (much later after a computer reboot) it failed again, and hasn’t worked since.

Oddly, exactly the same effect with using another PC.
I dragged out my laptop and it was able to copy a file to the WDTV, but again only once.

The second time I tried I got the usual error.

I’ve now discovered that I can copy files from the network using the WDTVs own copy utility. So far that’s working consistently.
So it must be a Windows thing, right?

Also as a Community newbie, I see now that I’ve posted this query to the wrong area (Live Streaming).

Would it be OK to repost my query to the Networking area, or would that be regarded as spamming?


1 Like

Well you can pm one of the moderators to do that, however you do have a Live Streaming don’t you?

If that’s the case it’s fine to post here