WDTV Live takes forever to start playing or react to the remote

I’ve had WDTV Live for 6 or 7 months now and in the last couple of days I started having problems that are really frustrating and I can’t figure out what’s wrong. I’ve updated the firmware to the latest version, but the problem didn’t go away, it’s all the same. I’m always playing movies from the attached portable HDD via USB, the network cable is almost never connected.

Yesterday I tried to play a file and for some reason it took forever to start playing it, even though earlier or the day before it worked without any problems. This time I think it was over a minute from the moment I pressed play on my remote, to the moment the file actually started playing. That circle in the middle of the screen keeps going round and round and round, but nothing happens for over a minute. But that’s not all. If I press pause, it reacts immediately and pauses the video, but when I try to resume play - it AGAIN takes over a minute to start. If I want to fast forward it, it reacts again and I can choose x2, x4 etc, but when I press play it just doesn’t react, it takes forever to actually accept what I pressed on my remote control. Same thing with the stop button or even the power off button, it takes ages to react.

I have no idea what to do, I’ve tried unplugging it for a few minutes, it didn’t work. I left it overnight last night and the same thing happened again today. Whether it’s the normal low resolution avi or high resolution mkv file, it acts the same. I tried plugging in a different USB stick and playing different files, but the same thing occured.

Does anyone know what’s wrong or do I have to return it cause it’s still under warranty? Thanks in advance.

Is it EVERY FILE?   

After you Reset it, is it the FIRST file every time?

Try putting a file on a USB stick, RESET, and then try the stick after the reset before you try the original HD.

Okay, I tried this. I unplugged the HDD and turned on the WDTV Live and it played the files on my USB stick as it should, there was no delay and it reacted to the remote control without any problems.

Then I plugged in the HDD and when I tried playing a file, any file, the same problem came back.

What could that mean? I mean, the HDD is almost new and it works flawlessly when plugged into the computer, I don’t think it’s a malfunctioning disk drive. What else could it be?

First try deleting the little WD file/folder on your hard drive (attach it to your computer for this).  Then reattach and see if it works any better.

If not, I’d try a reformat and put just one or two files on it before trying to play anything.

Thanks Mike, I will try that tomorrow and see what happens. I read a few posts here about problems with mkvmerge 4.2.0. I checked my files and I found one movie (added today) that was made with mkvmerge 4.2.0. I deleted it from the HDD, plugged the disk back in WDTV Live, but the same thing happened nevertheless. And besides, I had these problems last night anyway, when the file in question wasn’t even on the disk.

A few minutes ago I reset the unit to factory defaults, unplugged it completely and now I will leave it till tomorrow morning and then try again. I will also delete the wdtv folder, as you advised, and then we’ll see if that fixes it.

I really wouldn’t want to format the hard disk because it has tons of data on it, movies, music, my backups, documents, pictures… I don’t have enough room anywhere else to put all that stuff, so formatting will have to be the last resort. :frowning:


marin74 wrote:

I really wouldn’t want to format the hard disk because it has tons of data on it, movies, music, my backups, documents, pictures… I don’t have enough room anywhere else to put all that stuff, so formatting will have to be the last resort. :frowning:



I may get yelled at here (people have done this in the past when I bring this up) but let an old man lecture you just once – you are treading on VERY dangerous ground not having your data backed up.  All disks fail – just like tires it’s only a question of when, not IF.  So you are just asking to lose all your data.

If you don’t care, then don’t worry about it.  But if you value your data at all then you need to back it up, and you need to do it NOW.  Disk drives are dirt cheap (you can get a 1.5TB disk for around $80 and even a standalone drive doesn’t cost a whole lot more) and there’s no excuse not to do it unless you really aren’t worried about the day when you lose all that you have (which is coming, and maybe even soon).

You’re not gonna get yelled at, thanks for your advice, but I’m afraid you misunderstood. This disk actually IS my backup disk, but it’s not the only disk with my most important data. That data is stored on three disks,  this is one of them. But I also have tons of other stuff, like movies and tv series, which isn’t backed up (and doesn’t have to be cause it’s not crucial, but it would take forever to collect again) that I can’t store anywhere else right now cause I don’t have an additional disk drive. That’s why I said I wouldn’t want to format it.

Anyway, back to the problem. Actually after leaving the unit turned off for the night, deleting the .wd-tv folder on the HDD and deleting the movie that was merged with mkvmerge 4.2.0 - things are back to normal again. The frustrating part is that I have no clue which of those things actually fixed it and when it happens again (hopefully it won’t, but with my luck…), I’ll have to go through the same procedure all over again and see what happens.

Is there any word of a fix from WD, at least for this mkvmerge issue? If that’s the reason these things are happening, and it seems that it is, then a new firmware would probably rule out any future problem.

Thanks for your help, much appreciated.


There is indeed a fix for the MKVMerge problem and it should be coming out with he next firmware release (now the real question is when that will happen, but no one, not even WD, knows for sure :>).

And as to your stuff, well data that  “would take forever to collect again” is kind of the definition of data that needs to be backed up somewhere, unless your time really isn’t all that valuable.  I mean, NO data is irreplaceable, as long as you have the time to recreate it.  That’s the whole point – some time (and perhaps today) that disk will fail and you’ll be asking yourself whether it wouldn’t have been a good idea to spend a few bucks to save yourself “forever” or whether you have more time than money (at my age the answer is a no-brainer – I definitely have less time than anything else).

But… good luck to you in dodging that bullet (as well as not having any more Live issues.  But, if so, we’re here to try and help )

The Same thing has happened to me this week to a 1.5 tb WD elements HD, and I will first try erasing the “.wd_tv folder” on the harddrive and see if that helps. --I will let everyone know if that’s the fix to the Long delays in playback.

UPDATE: IT WORKS, So just erase the “wd_tv folder.” Maybe if it happens again in the future, just delete the folder again.