WDTV Live. Subtitles not working


#1

Hi all.

I just got my WDTV live delivered.

I’m trying to play a movie with subtitles. The movie is in .avi format and is located on my Windows 7 (64bit) machine.

Inside of this folder is a subtitle file named “example.srt” and the movie name is “example.avi”. 

I try to play the movie via media devices, and selecting the folder where it is, and then playing the movie. I select options, and subtitles… But it says there is no subtitles. I press enter many times but it doesn’t work.

I tried renaming the file to “example.avi.srt” and this does not work.

I tried renaming the movie. I go to the WDTV and the movie name appears as the old one.

All of these files mind you are in a public directory, and EVERYONE has read/write access. The workgroup name is exactly workgroup. 

I tried accessing the file via network shares, but I enter my login information, case sensitive and all, but it says incorrect username/password please try again.

I also rebooted my PC, after removing password, and it still does not work.

I’ve also reset the factory defaults, again, not working.

The only reason I bought this device was so I could play movies with subtitles (XBOX doesn’t support this).

The file isn’t itself not working, as this is the case with many movies with the subtitles in the folder.

I also tried connecting an external hard drive, but it isn’t detected for some reason (hard drive enclosed in a noontec enclosure). 

Any and all help/suggestions is welcome, I really am trying to get subtitles working, and I’m out of ideas.

Thank you.


#2

Welcome to the forums.

Okay, there are a number of issues here, so let me try and help you sort through them.  First of all, I don’t think playing files via media server will work with subtitles (I don’t use media servers so this is only AFAIK).  For the present let’s leave off using media server in any way.

Secondly, you don’t have to have the file extension in your subtitle name – so the “example.srt” is just fine (it just won’t work with media servers).

What we really need to do is get your net shares working.  To that end there are many things you need to check off (workgroup name, no Windows Live ID assistant, “Everyone” added to shares, etc.) but rather than go through them all I’d advise you to look through this FAQ and follow ALL the instructions relating to net shares.  Then if you still can’t get it working post back here and we’ll see where we can go from there (the non-working local drive is still another issue but we’ll get net shares working first).

http://community.wdc.com/t5/General-Discussions/WDTV-FAQ/td-p/32135


#3

Hi,

Removing windows live ID worked.

However I can only access D:. The subtitles do work.

However I have all of my media I want shared in the public folders.

How would I go about getting the public folders to show under network shares?

P.S: I should have read the FAQ more thoroughly.

Thanking you.


#4

I’m assuming you’re using Win7?

If so, then to get Public folders shared:

Go to NETWORK and SHARING CENTER.

Click the link to the left “Change Advanced Sharing Settings”

Choose the correct profile,

and make sure “Turn on Sharing so anyone with network access can read and write files in public folders” is selected.