WDTV Live+ Stops playing moves after viewing 1 movie on NAS (DNS-321)

So I finally got my D-Link DNS-321 2-Bay setup going and I try to play a movie hosted from it via my WD TV Live Plus unit. When I press play on the MKV file the screen goes black and displays the info bar on the bottom then goes away and nothing. I tried a few times on different files which I knowed it played when hooked up via USB and still broken.

I rebooted the NAS device and same problem. I unplugged all my cable modem, router (DIR-655) and NAS and retried and same issue. So I turned on my external HD via USB and it showed the same problem so I was really puzzeled. So it was the WD unit itself. Not the NAS or my external or my movies.

Anyway I unplugged the WD unit and plugged it back in, turned it on and it started to play the movie fine! I watched the entire movie 2hours and it ended. Hurray.

My problem hit again when I navigated to another folder on the NAS and tried to play and it did the same exact thing as before. Just displayed the info bar and black screen and nothing. When I looked at the NAS unit it wasn’t blinking on either the network or HD access activity so the WD unit wasn’t trying to pull data from it.

When I tried photos that worked fine but movies after watching 1 movie off the NAS device just puts the WD TV Live+ unit into a messed up state where it can’t read any more movie files?

This time I unplugged the network cable in the back of the WDTVLive+ unit and plugged it back in and then it read and started playing the movie fiel. The same one it was just playing for 2 hours straight 2 seconds ago. :womanmad:

Anyone have any suggestions or ideas?

Let’s forget for a moment the exact description of what you were doing – in general it sounds as if you played a “bad” MKV file (one that was made with MKVMerge greater than 4.0).  This will do exactly what you are experiencing (cause the Live to freeze and be unable to do anything else without a reset).  If you tell me for a fact you HAVE no MKV files then I’ll believe it was something else, but for now I’m going to assume this is the problem.

You can tell for sure – run MediaInfo (freeware) on one of your MKV files you are trying to play and it will tell you (you can post the results here).  If that’s the problem it’s easy to fix (just remux with MKVMerge 4.0 or earlier).

If none of your files are MKV then it’s a completely different issue – in that case you need to tell us how you authored them.

Here’s one movie info:


Complete name                    : Movie1.mkv
Format                           : Matroska
File size                        : 7.28 GiB
Duration                         : 1h 40mn
Overall bit rate                 : 10.4 Mbps
Encoded date                     : UTC 2010-10-06 19:13:30
Writing application              : mkvmerge v4.3.0 (‘Escape from the Island’) built on Sep  4 2010 23:38:20
Writing library                  : libebml v1.0.0 + libmatroska v1.0.0

ID                               : 1
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 4 frames
Muxing mode                      : Container profile=Unknown@4.0
Codec ID                         : V_MPEG4/ISO/AVC
Duration                         : 1h 40mn
Bit rate                         : 9 526 Kbps
Width                            : 1 904 pixels
Height                           : 1 056 pixels
Display aspect ratio             : 16:9
Frame rate mode                  : Variable
Frame rate                       : 25.000 fps
Color space                      : YUV
Chroma subsampling               : 4:2:0
Bit depth                        : 8 bits
Scan type                        : Progressive
Bits/(Pixel*Frame)               : 0.190
Stream size                      : 6.82 GiB (94%)
Writing library                  : x264 core 105
Encoding settings                : cabac=1 / ref=2 / deblock=1:0:0 / analyse=0x3:0x113 / me=hex / subme=6 / psy=1 / psy_rd=2,00:2,00 / mixed_ref=0 / me_range=16 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-4 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / constrained_intra=0 / bframes=2 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=0 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=9526 / ratetol=1,0 / qcomp=0,60 / qpmin=10 / qpmax=51 / qpstep=4 / cplxblur=20,0 / qblur=0,5 / ip_ratio=1,40 / aq=1:2,00
Language                         : English
Color primaries                  : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics         : BT.709-5, BT.1361
Matrix coefficients              : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

ID                               : 2
Format                           : AC-3
Format/Info                      : Audio Coding 3
Mode extension                   : CM (complete main)
Muxing mode                      : Header stripping
Codec ID                         : A_AC3
Duration                         : 1h 40mn
Bit rate mode                    : Constant
Bit rate                         : 448 Kbps
Channel(s)                       : 6 channels
Channel positions                : Front: L C R, Side: L R, LFE
Sampling rate                    : 48.0 KHz
Bit depth                        : 16 bits
Video delay                      : 1s 316ms
Stream size                      : 322 MiB (4%)

Text #1
ID                               : 3
Format                           : UTF-8
Codec ID                         : S_TEXT/UTF8
Codec ID/Info                    : UTF-8 Plain Text
Language                         : English


Here’s another one:



So if I remux it with this: http://www.videohelp.com/download/mkvtoolnix-unicode-4.0.0-setup.exe , it should fix it?

Page info: http://www.videohelp.com/tools/MKVtoolnix/old-versions#download

Yes, you can see that movie was made with MKVMerge 4.3 (greater than 4.0) and that’s why it toasted your Live.

Delete that file (or remux it with MKVMerge 4.0 or earlier) and all will be well.  (I’m off to bed but you can search these forums for “MKVMerge 4.0” for more details about this issue).

We cross posted – but that looks to be the right file (you’ll know once you install it and if it says MKVMerge GUI 4.0.0 at the top you’re in business).

Do you have an topic that explain what exactly which tool to use? Either MKVxxxx or could I use hand brake and I just open the video file then change what settings so that’s it now WD Friendly?

Also what is the reason why it messed up the WD TV Live unit if its built using a 4.xxx version?

The FAQ explains how to correct it the fastest way possible.

The WDTV doesn’t support MKV files that use Header Removal Compression.   All versions of MKV Tools after and including 4.1 turn HRC on by DEFAULT.  Further, attempting to play those files leaves the WDTV’s decoder in a bad state that can only be recovered by powering it completely off to reset the system.

Just copying the specific FAQ section here. I will try and post my results later on:

F) How to Re-encode

If you have a file that is not supported or causes playback issues on the WDTV, consider “Re-encoding” them using a program such as “HandBrake.”   ( http://www.handbrake.fr) Handbrake supports a large number of input file types, and software is available for Windows, *nix, and Macintosh systems.  Import the file into Handbrake, select the “High Profile” preset, and output to MKV using h.264 video.  Try the resulting MKV file on the WDTV.   If the bit rate is still too high, you can try increasing the “RF” factor to numbers higher than 22.  Quality will be degraded as the RF as increased, but so will the required bandwidth.  A side benefit of re-encoding is that the resulting files will often be significantly smaller than the source media with no noticeable loss of quality.


G) I still need help!  My file is causing problems and I don’t know what to do next.

Install the freeware software called MediaInfo ( http://mediainfo.sourceforge.net) Load the file with MediaInfo, and select VIEW/Text.  Copy the results and paste them along with your question into the correct forum topic.

H) I have some MKV files that the WDTV doesn’t play.  Either there’s video but no audio, or vice versa, or doesn’t do anything!

The Matroska specification allows for a form of compression called “Header Removal,”  that before recently was rarely encountered.  The WDTV Live players do not yet support this form of compression, and may not give an error if it’s encountered. 

Recent versions (Version 4.1.0, July 1, 2010 and later) of the popular MKVMerge tool (which is used to create many MKV files) turn this feature ON by default on audio and certain video tracks.

If you suspect that this is your issue (MEDIAINFO will report the Writing Library as MKVMERGE Version 4.1 or later) you can correct it by loading the file into MKVMERGE, then selecting the track(s).   Click the Extra Settings Tab and set Compression to NONE.  Re-mux the file.  This turns OFF the Header Removal Compression and restores the file.

The MKVInfo tool will also explicitly state the form of compression used for each track.

I) After attempting to play an MKV file affected by the issue described in FAQ 4H, I am unable to play ANY type of file.

As described in Section 4H, certain MKV files will not be playable.  Further, if an attempt is made to play such a file, it may render the WDTV unable to play ANY video files after that.    The main symptom of this is the “Loading” indicator circle continuing to spin without the video ever starting.

To recover from this condition, perform the steps outlined in Section 1G.

Ok when I opened mkvmerge GUI v4.0.0(The Stars were min) I opened the mkv file and I see the 3 tracks, in the Extra Options tab on the bottom the compression drop down menu is grayed out for all the tracks I select on the top.


That’s fine.   MKVMerge 4.0.0 doesn’t support Header Compression output, so you’re good to go just LOADING and doing a REMUX without changing any options.

Wait a sec. Where is the firmware download URL for the WD Live Plus device? I just tried searching for it and cannot find it on the site?
Also I found the beta firmware and noticed this little tid bit:

" Resolved MKV playback issues relating to mkvmerge."

  • Resolved Netflix random reboot issue.
  • Resolved Netflix frame rate issue.
  • Resolved MKV AAC on-the-fly mode switching.
  • Resolved MKV playback issues relating to mkvmerge.
  • Resolved MP4 problems with seeking and audio stopping.
  • Resolved MP4 poor frame-rate and audio out of sync.
  • Resolved sub+idx subtitle not working for supported subtitles.
  • Resolved adjusting idx subtitle position which causes video to lock up.
  • Resolved 12 bit color depth has no effect.
  • Resolved no audio for mpeg video when digital audio is enabled.
  • Resolved component user interface color space.
  • Resolved various user interface translation issues.

So maybe I’ll apply this beta and give it a shot…


Thanks. I saw and found that previously but where is the basic page for the WD TV Live +?

I see this page: http://wdc.com/en/products/Products.asp?DriveID=832

and then in the Specifications Tab, there’s a Downloads and Sotfware link that takes you to:

but there is no Firmware Info? Ok maybe b/c they having released an offical one yet. When compared to the regular live I see it has a firmware link. Ok I’m good then.

There isn’t one, because ALL WDTV Live Plusses come with the SAME version of code, and there have not been any additional releases.

BETA code is not distributed or advertised via the Product Information pages.

Awesome!! The beta firmware fixed this.

Grab it here if you have this issue: http://wdc.com/wdtvliveplus_limitedpublicbetarelease/

I just hope they put this out for the WD Live Unit as well. I have both.

The scuttlebutt I heard from WD… and this is just what I heard, mind you… is that the Live update was designed in tandem with the Live Plus.  The Live update is waiting on the same HDMI issues that they’re dealing with in the Live Plus.  When the one is ready for final release, the other should be ready, as far as I’d heard.

I have the same problem with the unit and with DTS found shutting off the WDTV and on again then it will work.

But DTS sound will quit within a moment ot two later.

It’ll do all kinds of abnormal things if the MKV file has header compression enabled…

That IS a bug, and the beta software has corrected it.