WDTV Live SMP - Media Library Can't Access Desktop Video Folder Windows 7 - Read Only

There’s another thread on this, but for some reason I cannot reply to it, so I’m starting a new one. Using Windows 7/64-bit. I was able to create a Media Library with my WDTV Live and can successfully access three external hard drives connected to my desktop computer. But I cannot include the files in my Windows-“My Videos” folders/library because it appears to be “Read Only.” (It has the square in “read only” when I click on Properties, and removing it impossible.) I’ve researched all the Windows issues with respect to the “read only” attribute, but nothing seems to work. (I have full control and am the owner of everything on my computer and I am the only user.)

Is the only way to have these files accessible to my WDTV Live to move them to one of the external hard drives?

How are you accessing the PC.

Is your my videos folder shared on your network.

I can’t see that the read only will make any difference as I assume that you are only trying to play them which only means reading them.

Have you tried using network shares to connect to your PC, what folders do you see.

Having read only drives/directories/shares will prevent the WD SMP from writing database files to them. That is likely to prevent their use.

You might want to try sharing the folders that contain the content that is in the “My Videos” library rather than pointing to the library itself. Also, it is possible to properly share libraries with homegroups and make them read/write. Have you tried that yet?

All of my file directories say that they are read only but it does not stop me adding files to them or deleting them.


Remember that you are using two seperate sets of permissions in this situation which may be having an effect. The “share” itself has user permisssions, and then your files system has permissions as well. From the local machine, only the file system matters; from your WD or another computer, you are dealing with both sets. The most restrictive of the two sets of permissions will take precedence.


Not sure how your setup is, but AFAIK, the media library must be able to write to the disk to update the media library’s DB. The manual specifies this for USB drives (though not about networks shares), but I am under the impression that the process is the same. I’d give it it a test but I don’t use the media library.


Hi again and thanks for your answers. I admit I’m really confused by how all of this works, and I used to consider myself reasonably tech-savvy for someone my age (61.)

I was able to get the WDTV Live to include the folders that have the blue “read only” square in the Media Library, finally. I’m not sure how I did it or what changed, but it worked. However, I do have other issues: For example, one of my external hard drives is shown as included in my Media Library, and its status is “Ready,” but it doesn’t show up when I actually open the Media Library. When I try to re-add it, it says it’s already included. Don’t know how I can fix that (and, by the way, it did work previously.) And while it lets me re-scan it, nothing actually happens when it does.

I’m also confused about the difference between the Media Library/Windows Share and the Media Server. I can seemingly access the same files using “Media Server,” but video playback is spotty (freezes up and speeds up and other issues.) I have this same problem when I attempt to stream my computer-based video files using my Blu-Ray player to access them.) Also, the files never show up as “xx New Items” like they do when they’re in the Media Library.

And I get random weird behavior from time to time when I start up the device – like having the previous device not found, but then having it show up later, or items disappearing and reappearing in the Media Library.