WDTV Live - requires constant reset - frustrating


I got the WD TV live from best buy and I am running the latest 16 firmwar that got upgraded a few days back.

the problem is that the device hand each time I try to play a any file - I have stuff converted from DVD or Youtubes - kids stuff - and I have do a full reset each time in order to get it to play.

after a full reset  (all everything reset) - it will play a file one time - and then get will not play anything else. IT shows the menu - but on clicking a file - it shows the “loading arrow” and doesn do anything. a full reset is now required for anything to work.

Also - when playing a movie - after about 2-3 mins of playing - all controls stop working - and any action - like menu etc - works, but the movie is plating the back - and it does it not work anymore.

everything second action require a full reset.

the disks are both local USB and Network NAS shares. the issue is bugging the **bleep** out me and my kids… tried all sort of debug/ reset  - the only thing remaining is to try and throw the device against a wall and see what happens.

any help.

I have also returned the device once and replace with new device and same issue.




sorry - I meant the 1.06 firmware - upgraded from 1.05 a few days ago.

still no fix.

There’s one bug that would not play any files after one file failed to play unless the device is powercycled but I’ve never read of this weird behaviour. If youre on 1.06.43 now, you could rollback to 1.06.15 and then to 1.05.04.

sounds like the same problem I have. I can start a movie and aftar 2 3 or  5min my HD Live TV shuts down I can do nothing. If i wait 5-6min it restarts itself but not always it right. Somtimes it like freezes and won’t connect to network. In most cases I need to pull the plug to get it properly back on and often need to do so a couple of times before succeding


This has been happening to me for a long time.  And it is happening on both of the WD TV Live units I have. 

Reverting to an earlier firmware has not helped, I even tried an open source firmware, no difference.

What seems to happen for me is like the connection between the controlling software and the playing hardware breaks after a few minutes (whether it is playing or not) and so if it is playing, the playing continues regardless, although you can still go back to and navigate the menus.  If it is not playing, then it will not start playing.  Only a hardware power cycle sorts it out.  (Developers, how about a menu option for doing a reset on the player hardware?  Possible?)

Sadly, I have no solution, although a bit of web searching suggests maybe some smartphones on the same network might search out (and accidentally interfere with) DLNA devices such as the WDTV’s.  Haven’t had a chance to test that theory yet though, will post my findings when I do.

Which devices are y’all talking about?   The WDTV Live subject of this forum doesn’t have a “Loading Arrow.”  it’s got a Spinning Wheel.  The newer Live SMP has the arrow, as do the Hub & Play.

Regardless, ALL WD players have a menu option to restart the player.  On the newer boxes, it’s under Settings / System / System Restart (or something like that.)

Many of the players, regardless of the model, have an occasional issue that crashes the “renderer” code that plays back videos.  If it renderer fails, no media will ever play again until the box is restarted.

Using the word cautiously, “most” times this is due to playback of bad media.  

TonyPh12345 wrote:

ALL WD players have a menu option to restart the player. 

The WDTV Live on 1.06.43 has not.

(*knocking myself on the head*)  So they took it out?  

I remember using it frequently.  But I stopped using the Live/Live+ pretty much after the SMP got its act together, or maybe my brain is playing tricks on me.

I have a similar problem, but not quite as bad. My unit does not require a reboot after every play, but often does just freeze up and requires a reboot. Also, even though the unit does “OK” in streaming a Netflix or Hulu movie, getting there is painfully slow. The initial boot, connecting to my wi-fi, getting to Services, getting to Netflix, … Is all painfully slow. By the time I finally get a movie started, I am about out of the mood. I usually just give up and hook an HDMI cable from my laptop to the TV, and get on with it.

This device is incredibly slow as well as unstable, not to mention no standard general browser (except under a hidden hack). A great concept, but I am very disappointed in this unit.

TonyPh12345 wrote:

(*knocking myself on the head*)  So they took it out? 

Actually, I’m pretty sure the old Live never had it. They indtoduced it with the SMP and I’ve always wondered why the haven’t ported it back to the old devices. Seemed like a no-brainer to me…

My Live Plus doesn’t have a restart control either,  So my “restart button” for the Live Plus (as with many of my other black boxes without a power button) is to purchase (at Home Depot) another wall-wart type of on/off switch that the box plugs into at the wall outlet.  Seems I have bought plenty of these, as most products forgo the power button anymore.  Kudos to any new products that still include the power button!

Heheh…  consider me “schooled.”  :)

It’s no surprise you thought all players had this cause that’s just what one would expect, especially given how buggy those firmwares are.

What part of   FROZEN  do you have a problem with comprehending?

When something is FROZEN, how does one navigate to ANY setting? [Deleted]

Yeah, except the WD Live TV Hub that DOES have a power button has one that DOES NOT WORK WHEN THE BOX HAS FROZEN.

The ONLY thing to do is to unplug/replug it back in.

And by doing so, you’ve lost your place in the movie.  Hope you can remember how long you’ve been watching.  And then hope you can fast-forward without freezing the box (again).

I also had frequent lockups. Mostly solved by:

  1. Set the device vertical for better cooling and dont let sunlight cast on the unit.
  2. Disable media library. It scans for content changes and that just doesnt work well. It overheats the unit and has issues with large media libraries.

Then there is the issues if certain apps like netflix. Netflix is just very unstable. The regular media player almost never hangs the unit anymore.

Why hasnt this been fixed yet?  Uhg… I am so DONE with WD Products.

I have 5 WDTV Live boxes and all of them have this issue.  I have to constantly unplug the box to reset it in order to play files.  I did NOT have this problem when I first bought the boxes many moons ago.

WD: What is the status?  Why isnt this fixed?  This product is NOT operating as expected.

1 Like

I have 4 and none of them have this issue.

Then why are you in this thread?

1 Like

I have two Live Plus units and they play fine.  Rarely do they crash.  I play video files from known and reliable sources (i.e. I make them myself)  I mostly play media from drives directly connected to media player, yet often stream stuff to the WD through the wired network or via my iPad, wirelessly. I have a good gigabit home network.  All is fine and well.  Problems can occur for folks if any of these factors are out of whack.