WDTV LIVE Reboots after connecting to network with Cisco-Linksys WUSB600N Wireless Dongle

Started after I upgraded to 1.04.17_V.   Though I did test the WDTV after I updated it and it seemed to work fine.  Went to use it again  and now the WDTV reboots as soon as it connects to the network.  If I disconnect the USB dongle the WDTV does not reboot.   I tried rolling back the firmware but it’s still happening.  Has the latest firmware corrupted the wireless drivers permanently?  Or is my unit just defective now?

I assume that I can still watch videos off a directly connected drive though I haven’t tried yet.  I also need to see what happens if I try connecting through ethernet.

Did a google search on “WDTV Restarts” and found this:

my new wd tv live keeps restarting in every 20-30 second…

so far I narrowed the cause of the problem by eliminating most of the factors in my environment. I want to write the progress here since there is nothing in the forums about this problem. I was planning to return the unit back to mediamarkt but it seems that I will not need…

  • no network cable no reset problem

  • upgraded to latest firmware, still crashing after reboot.

  • wire or wireless (samsung wireless 802.11n usb dongle) does not matter,after getting the the ip from dhcp it reboots.

  • internet connection does not make sense, I tried to give manual IP (without default gw or with def gw) it keeps rebooting

  • dhcp or manuel IP does not matter.

  • I realised that the problem is inside my network since I connected the unit with a crossover cable to my laptop and it did not crashed. which means that the hardware/ethernet port is not faulty.

  • there was a windows vista media center version Mini PC (Asus PX24) on the network and when I disconnect that PC from the network, WDTV live stop rebooting (yep I found the cause)

  • I disabled the running services and programs on PX24, the samsung share manager ( dlna software) ,etc but could not find the cause yet.

  • I will trace, using ethereal, to see which packet/protocol crashes the WDTV but its so interesting that the wdtv-live is this much buggy. I think they released it in alpha stage to catch the cristmas season.


I saw that wd tv live trying to talk UPNP with the PX24 and WDTV is trying to send 200 OK to a closed port of the PX24 ( I dont want to debug the protocol (IMG: style_emoticons/default/smile.gif)

Could there have been an Windows update in the last 3 days that fubar’d my WDTV?   It has happend before.

I know this doesn’t help you too much, but I have a WUSB600N wireless adapter and it is working OK with 1.04.17. I still have the VOB stuttering problem that was introduced in 1.04.10, but the wireless adapter seems to work OK otherwise.

Yes,  after finding the above post about the network issue, i’m thinking it may not be a fw issue.  I’ll be testing it out tonight.

Regardless of what you find, my opinion is that it IS a firmware issue…  Even if something else on your network has a Bug, the LIVE shouldn’t be so fragile that it reboots in its presence… :wink:

Good point.

So I rebooted my computer and now the WDTV no longer reboots when connecting to the wireless network.  Strange.