WDTV Live reboot loop after firmware update

Hi All,

I have been using WDTV live for few years with no issues and recently there was new firmware update avialable I am guessing from the release schedule it was  Release 2.02.32. I upgraded the firmware a week ago and since then my WDTV live is in a reboot loop. 

Symptoms: When I plug it in, it try to boot and I see the WD screen and then screen goes black and reboot.

Cause: Upgrade to  Release 2.02.32.

Troubleshooting so far:

  1. After reading forum for similar issues, I disconnecting all wires, Ethernet, Audio, USB drives etc. except HDMI and try rebooting, but it didn’t work.

  2. Tried pressing reset button for more than 15 sec, but it didn’t work, maybe because it never completed the boot?

  3. Tried downloading firmware so I can rollback, but there is no way to install the firmware without going into setting and I can’t get into setting because it just don’t boot completely.

Please any help is appriciated, if this box is bricked, please let me know too.

Sorry to hear that you are getting this situation.

See if the following link helps.


Well I have seen that post and tried everything from that post… but as I posted in my original post, my WDTV live doesn’t complete the boot, so I can’t chang setting to rollback the firmware or anything.

No relavent reply in more than 2 days… seems like there is no fix for this issue… I will assume my WDTV is bricked and I should be in market for a Roku or Fire TV.

Maybe you should try contacting WD’s Technical Support about this. You can do so either by phone or email.

To Contact WD for Technical Support

Support by Country

Hi, any luck with support? I am having the same problem. Black screen and solid LED showing but doesnt finish booting up.

The exact same thing happened to me last night, but don’t think it was triggered by a firmware upgrade.

I’ve emailed support, so we’ll see if I get a response.

Very frustrating though.

I’m not saying this is a fix … but it’s worth reading these posts, (sounds similar) i guess :neutral_face: