WDTV Live - random avi files being converted to folders

Can anyone confirm that downgrading to 1.05.04_V will resolve this issue?

Remember you shouldn’t downgrade from 1.06.34 to 1.05.04 but to 1.06.15 first.

1.05.04 has no disk corruption issue. And it has auto frame rate, which most of the intervening versions are missing. The version I’m still using

After saving my files using Lubuntu as reported previously in this thread (and removing any corrupt stuff this way) I’ve downgraded to 1.06.15V, and so far I don’t seem to have lost anything at all.

Not really surprised since I never had this problem before, but happy for now nonetheless! :slight_smile:

Folllowed the same process. 

Installed Lubuntu on a 2GB pen drive.

Booted with Lubuntu, browsed to the currpted folders and copy pasted (over write) the currupted files. 

That worked.

Downgraded to 1.06.15V 

It showed “New Firmware found” option only after editing VERSION=‘1.06.15_V’    to    VERSION=‘1.06.44_V’ in the Firmware folder.

Downgrade successful.

Didn’t see any corruptions after that.

But, I would like to know if WD is planning to fix this and planning to release a new version??

Is there any benefit to separate 2 terabytes of disk unit in 1 terabyte?

Hi there

tried to follow your instrctions, using Lubuntu 13.4, but even though I can still the the files, the cannot be accessed under LINUX. Also tried other LIVE distributions, I always get i/o errors.

Does anyone have the same problem or even ideas?

Hi All,

I also experienced this annoying problem.

If you have any information about restoring files, please share it!



Reformat – Restore from backup

capaeledel wrote:
If you have any information about restoring files, please share it!

Other than that already given in this thread? Or does this method not work for you?

I have the same problem. I contacted the tech support via email and got the response cited below. This just a standard response and I’m almost sure that it won’t solve the problem. I did all the steps but have lost all confidence in the box. I 'm not sure if it is worth the work to restore all files and then the device would possibly destroy them again.

I think this is a severe problem but WD does not fix it.  I should backup all data on my 2 TB Disk? Good idea, so they have the chance to earn some money when I buy a second 2TB disk!! 

When restoring files via lubuntu, I saw that the problem is EVEN WORSE! Lots of other files are not turned into empty folders, but are even unreadable, lost forever: I/O error is reported!

It is not acceptable that a multimedia box corrupts attached hard drives!!! We should start a **bleep** storm to force them to do something.

1.	I highly recommend backing up all the data from your WD Elements to another source.
2.	Try to reset the device while it’s on. Press the Reset button on the side of the device. Hold it down for 1-2 seconds. The device will reboot.

Detailed instructions on page 7 of user manual:
3.	Reset the device to factory settings. Go to Settings - System – Reset to Factory Defaults and press OK. The device will reboot. Detailed instructions on page 140 of user manual.
4.	In case the firmware got corrupted during automatic update, try to update the firmware manually....

The only way to avoid the problem is to downgrade firmware. And you should always backup your files, all disks break eventually.

Cocovanna is right. You need to install older firmware to avoid the problem.

Another alternative is: rather than connecting the external drive to to one of the usb ports on the WD box, instead connect the external drive to your computer and access the files using Media Shares. I have never had any problem accessing external drives that way.

Which version of firmware is free of this bug? And was there not the problem that it has been removed from their site? And was there not a problem that it can’t be downgraded to directly, you have to owngrade to an “intermediate”  firmware version first, and after this is done the bug free FW can be downgraded to? 

Not really convenient…

What I said is not against you both that gave me hints, thanks to you.

I’m just unhappy about WD, I would expect them to fix this severe firmware bug in a new firmware. Of course I backup all important files, but a device that is known to **permanently** destroy data on my harddisks just can’t be compared to a breaking hardisk, that happens very seldomly.

And who has enough harddisks to backup 2 TB? And if I know my WDTV will destroy data again, after I have restored it, and I am all the time busy with repairing it again, should I accept that ??

P.S. I also had the idea to put my harddisk to my computer and access them via net access/streaming server, and that’s what I’ll do in future, but I loose a main benefit of this small energy-efficient “media server”, if I always have to turn on my computer too, to use the box.

…this situation with  WDtvLive could be compared to a car that breaks down every two weeks. When I complain to the manufacturer, he just says: "It’s not my fault! Don’t you know  that you need to have a backup car! "…HAHA

batmanundrobin wrote:

Which version of firmware is free of this bug?

The one that is listed in this thread. 4 posts in a row but you can’t be bothered to read the previous pages? Really?

Scandy wrote:

… Another alternative is: rather than connecting the external drive to to one of the usb ports on the WD box, instead connect the external drive to your computer and access the files using Media Shares. I have never had any problem accessing external drives that way.

Fully agree with the above from Scandy. I am running 1.06.42 on my LivePlus with all my media on remote machines, most on a file server, and a little bit on my LiveHub. Never had the issue accessing my media this way, and after following this issue for the past 9 months wouldn’t even consider taking the risk on that type of data corruption.

 BTW, I have read several posts here and other threads on this topic with people complaining about losing their data/media or having to backup their data to fix the issue. I am going to purposely be semi-harsh here, but if you don’t already have a backup for your data you are absolutely setting yourself up for disaster. Back it up ASAP, as in immediately. We are all constrained by our personal finances, but disk space is really cheap these days, especially compared to your time. Though you could spend a lot of $$ on an awesome RAID setup and remote backup system, you can easily build a really inexpensive system that simply copies your files to another drive somewhere, or even the cloud if need be. One copy of your stuff is just asking for it. I don’t care that I still have the original DVDs and CDs. Just the thought of re-ripping multiple TBs of data would be enough to make me want to rip my hair out if I had any. I am about as cheap as it comes, but I still mirror my data (well similar but not really RAID) with Drivebender ($18), then robocopy (Free with Windows) it to a different device on a schedule, and then have the hard copies as a last resort. Sound like overkill? Maybe so, but well worth it IMHO for the peace of mind you get.   Disks die, data gets corrupt. It happens all day, every day to someone. If I lost my movies/music, I am not sure I would even have the wherewithal to go through the ripping process again. I’d probably end up flipping CDs and DVDs in my Blu-ray player instead, with my WD Devices sitting idle. Sorry, I know I am not your Dad, and have no right to tell you what to do, but had to get that out.  

So back to my original thought; if this issue worries you, move the external drives to another machine and attach to them over SMB/NFS or DLNA. Works great.

Good luck to all with this issue. Even with the fix, still sounds nasty to me.


I’m still at 1.05.04 as this is the last non-corrupting FW with Auto-Frame rate (needed because my DVDs are 25f/s, BDs are 24f/s).

And I actually have TWO backup copies of my media files. Reripping is a HUGE work, especially with those discs needing special treatment