WDTV Live - random avi files being converted to folders

I have had two Live Plus players, each with it’s own 2TB WD drive, for quite some time and have never had any corruption on either.

After the last FW update, both drives have had various .iso and .jpg (thumbnail) files converted into empty folders with the same name.

Different files on each player, and it keeps happening to more files as time goes on.

I only access the drives over a network the drives are never removed from the players, and the players are always on.

(Rolling back to the previous FW version today)

Can you do that? Revert to a previous version I mean? How?

if you google “rollback live plus”, there is a wdc help page which has a link to the rollback firmware which is Firmware Ver. 1.06.16_B.

You basically copy the three files to the root of a USB key, plug it in, and you will get the “New Firmware Found” message.

The version will actually say it is 2.xxx but it is really 1.xxx once it is installed.

After that, you just need to do the same thing with the 1.06.34 firmware.

The link on download.wdc.com doesn’t seem to work anymore.

The filename was wdtvliveplus_1.06.34_B.zip. Maybe you can find it somewhere else.

Maybe 1.06.34_B was pulled because it was unstable.

Do some reasearch and decide which version you want to use.

Good luck!

Pretty much the same story for me. I have used my WD TV Live Plus for several years with one attached USB 2TB WD drive. After the most recent update (1.06.42_B) I had several playlist files (.pls) changed to a directory and made useless. Thankfully, I have all my video files under a directory /.hidden/Video/ that the WD box doesn’t even see. This limited my destruction to the files that can be seen - my playlists and the associated .jpg thumbnails for the playlists. Both of these I can easily recreate.

There is another thread where .34 was removed by wdc

“Firmware 01.06.34 Removed from update page”

Although I haven’t noticed any problems, I think I am going to rollback to 1.06.16.

Haven’t noticed this in the last couple of weeks but live in terror of suddenly finding my 2 TB of files suddenly being converted and lost.

Yes it seems to only have happened since the last firmware update, hasn’t anyone had any issues after downgrading? And what’s the exact process for downgrading?

This same issue happens with .34. I have had more .iso and .jpg files converted to folders.

I must have been using .16 prior to the .42 update since I see a feature in .34 that I know I didn’t have before.

I am rolling back to 1.06.16_B.

Hopefully that will preserve my drive contents.

Thank you everyone! Rolling back saved the day! 

Anyone knows if 1.06.43_V suffer the same problems?

I rolled back both of my Live Plus devices to 1.06.16_B.

It been about a month and none of the files have been converted to folders.

1.06.34_B was bad

1.06.42_B was bad

I’m running 1.06.43_V and it’s doing it!!!

ARGH!

Is WD aware of this?    Are they planning on fixing it?

Hello,

We had reported this issue to WD, they forwarded to the WDTV department.

Every firmware prior to 1.06.34 should not have this bug.

The created folders are not empty, but invalid. AFAIK they can only be removed by reformatting

The same problem here. I have downgraded the firmware hoping to save my files. Now the WD TV Live starts with message “new firmware available”, and I have to ignore this. Nice.

hi

i am having the same problem. not sure when this started happening but I was reviewing some folders and found a lot of files converted into empty folders with the same name (all kind of files)

I too am having this problem. So far its only been on my 2TB WD external passport drive.

I have the same issue, and will try to downgrade to get it solved as suggested here. I have the original WD TV Live (1.06.43_V).

I’d like to add something for people who’ve been losing files, though: I’ve observed that I can still access and copy the files (which makes them valid again) using a Linux distribution. I used a cd-version of Lubuntu that didn’t have to be installed. This may save some people a lot of time recovering their lost files :slight_smile:

But can you remove the invalid dirs with Linux?

Yes. But better still, you can recover them.

What I did was the following:

  1. Plugged the HDD into my computer.

  2. Looked up all files that were converted into ‘folders’ and made a note of them.

  3. Booted up Lubuntu from a bootable install cd; ran test environment (doesn’t require an install – see their pages for instructions).

  4. Browsed to the files that were converted into ‘folders’, which all looked normal.

  5. Copied these files to my internal hdd.

  6. Rebooted into Windows.

  7. Copied the files, which were now readable, back to the external HDD.

  8. Problem solved.

Or at least: files recovered. But I’m hoping my firmware rollback has also solved the problem :slight_smile:

2 Likes