WDTV live, problem with MPEG-PS files


#1

Hello,

I have two types of video file that I wish to play back on the WDTV Live media product which are causing me problems.

The first type of file is in an .mp4 (MPEG-4) container. The following image is the encoding information obtained using the MediaInfo application:

The second type of file is an MPEG-PS (.mpg) container, with the following encoding information:

With both file types, the video will be displayed with no problem. The audio (despite the track being recognised) will not work however. Sometimes the video is completely silent, sometimes it sounds like broken white noise.

I’d greatly appreciate any help on fixing this issue.

Thanks,

Odai.


#2

Both of those audio tracks are unusual – they are 1 channel, which is almost impossible to find nowadays on any commercial media.  How did you encode these?  Where did the originals come from?

They can both be easily fixed by running them through ffmpeg.


#3

Many thanks for your helpful reply.

The second type (the mpg one) is the format of the video recorded on an old-ish Sony Digital camera. The first type I am not too sure, it is a very old file. I have never transcoded or altered the files in any way, they’ve come straight from the sourse.

Both worked fine on the built in player that came with my Sony Bravia LCD TV, which is very restricted in terms of what it will play.

Incidentally, different programs are reporting different codecs being used. Media info is saying MPEG (-1?), while TSmuxer states MPEG-2, as does the TV.

The manual states that MPEG audio and MPEG 1/2 is supported with the MPEG-PS container format, so I’ve got no idea why it’s not working. :cry:


#4

If command lines don’t scare you, try this with ffmppeg:

ffmpeg -i filename.mpg (or whatever) -acodec aac -vcodec copy testoutput.mpg (or whatever extenstion it already is).

This should fix the audio track while doing nothing to the video.


#5

Hello,

Sorry to take so long to reply, I’ve been busy with ironing out other issues with my player. :stuck_out_tongue:

Unfortunately, I am not tech-savvy enough to understand what you want me to do. :smileyvery-happy:

What I don’t understand also is why the sound isn’t supported when the WD manual clearly states that the relevant codecs and containers are supported. Even my crappy Bravia TV could play them without issues. :stuck_out_tongue:


#6

I can’t speak for the WD marketing folks.

What I gave you was the relevant command line for using ffmpeg.  It’s a freeware progam for converting a wide variety of audio and video but it does require a bit of ease with such things.

If that’s not your cup of tea (and you don’t mind re-encoding your video) running your files through Handbrake will fix them a lot easier.  It’s also freeware available for all platforms – just install it and use the High Profile preset (only change the output type to MKV) and you’ll be home free.


#7

I’ve had a look at those suggestions. Unfortunately, re-encoding the video resulted in significant quality loss and will take a very long time to do. I’ve found a more convenient way of doing it, using a program called “MediaCoder Audio Edition”. However, I am not sure which coded I have to select in order for the audio to work on the WD TV. Any ideas? 


#8

AAC is a very safe choice.


#9

OK - there are options to try the FAAC, CT AAC+, 3GPP AAC+ encoders. Which one should I pick? Will the bit rate and “MPEG option” (2 or 4) be relevant to whether the WD TV can play it?


#10

Since I don’t know anything about the program you’re using I can’t say for sure, but offhand I’d try FAAC (if it doesn’t work, try one of the others).


#11

Nothing worked, so I tried handbrake. Handbrake degraded the video quality and made it almost impossible to sort out large numbers of video files due to having to sort out each one individually.

I tried WinFF, this allowed me to convert all the audio to AC3. Before remuxing the many audio AC3 files back into .mkv files with the video streams, I tried playing back the audio on the WDTV to make sure it works. Everything was fine. I therefore muxed everything back together ( so now I have the original video streams which worked fine, and the new AC3 audio in a .mkv container). However, I tried to play the new files, and it’s exactly the same problem. No audio. With some files that use MP4 video streams, the file can’t be played whatsoever.

I’ll try FFMpeg now, but will this work considering the other results? Also, I am totally unsure of how to use the program to fix the audio on many files at once (queued). Is this possible? Once I have downloaded and extracted everything, what exactly do I need to do/launch? I downloaded from this page:

http://www.ffmpeg.org/download.html


#12

First things first – if you used Handbrake with the High Profile preset (and only changed the output type to MKV but left everything else alone) it would not degrade your video and would sort out any audio issues you had.  You can queue up the files (you can even put them in a folder and it will process the entire folder, but you have to use one of the nightlies for this to work, and not just the older release version).

FFmpeg is command line driven and thus can’t do more than a file at a time.  There are GUI interfaces for it which might be able to do this, but I am not familiar with them (but perhaps someone else will jump in here).


#13

From what I understand, following those instructions results in the video being transcoded using x264. Doesn’t any transcoding whatsoever diminish the quality of the video?

How can I obtain a version of handbrake that you refer to which is capable of processing entire folders?


#14

Sometimes you just have to trust what people are telling you – this is one of those times (or, as Spock once said “A difference that makes no difference IS no difference”).  Use the High Profile and you’ll be just fine.

As to getting one of the nightlies, read this:

http://forum.handbrake.fr/viewtopic.php?f=6&t=15901


#15

I hope so anyways. :stuck_out_tongue:

I’ll give it a go ASAP. However, I had already tried using handbrake with one file previously and I ran into audio sync issues. Will see if the problem persists.


#16

OK, tried it, but it just doesn’t want to co-operate. :stuck_out_tongue:

When I open the folder, I have to select each video file individually and add it to the queue. The automatic destination path and naming do not work, and the biggest problem is despite adding each file individually to the queue, it only encodes the longest video and just repeats it again and again. For example, if I select 20 video files for encoding, it will just transcode the first video file 20 times and make seperate copies.

I’m assuming it’s a bug. So handbrake doesn’t work, neither does FFmpeg or any GUI front-end I get (the resulting AC3 files stop working on the WDTV once muxed in with the video), or audiodecoder.

Is there any other way to fix this?

Should I take it up with the official WD TV tech support, as it is stated in the manual these files/streams should be supported to begin with?


#17

Since I’ve never used the entire folder coding process that’s something you’d have to take up with the Handbrake forum folks – but you never said whether the video you encoded works or not.  If it does, then I’d keep at that approach if it were me, because even if you have to add each video separately (one at a time) it’s no big deal (can’t take more than a few seconds per video, and even if you had, say 300 videos to convert it won’t take you more than ten minutes to add them all to the queue).

If you mean by “official WD TV tech support” calling the WD people I suspect you will get no where fast, but it’s up to you (the phone support people seem especially clueless about things although, to be fair, every now and then they have answers to current hot issues that don’t seem to make it here, like the Netflix reset bug).  But as to whether these files should be supported – um, no, mostly that’s just the PR department talking.  The Live doesn’t (nor can’t) support all the various flavors of all the things that can be contained in every container out there – the best it can do is support some of them very well (and this is true of ALL such media players, which is why Apple so strongly limits what theirs can even accept).


#18

Well, I’ll keep at it then and try and convert those files. Still, I don’t understand why converting the audio to AC3 works fine until I mux it back in with the video stream. Thanks for your help!

WRT the supported formats, surely it’s false advertising to claim in the technical specifications that it supports this format when the unit doesn’t actually play it at all?


#19

Odaik wrote:

 

WRT the supported formats, surely it’s false advertising to claim in the technical specifications that it supports this format when the unit doesn’t actually play it at all?

 

It probably does play those formats but just not the way your files are put together. There are hundreds of ways of making these files and they may not be entirely to the spec that the WDTV expects.