WDTV Live plus files stop playing after 5 minutes


#1

Hi all,

WDTV been setup for a few weeks and had been working fine. Have shares on an attached USB drive to Asus RT-N56U and also on desktop PC/Win7 network shares. Can access shares on both with 2 laptops running XPPRO SP3 & Win7, also Macbook and 2 droid tablets. PLUS  desktop and laptop running MINT14 can connect to Asus/USB drive and play videos fine.

WDTV says network connections OK. signal strength is 1 to 2 boxes, however WIN7 laptop right next to it says strength is alot better on signal.

Reset to factory defaults and tried it, same problem. Running latest firmware

Went to use it after it had been off for a few days.  Movies play for 5 to 10 minutes and stop, WDTV then shows network shares folders. THEN, its takes forever to hook back up. used GUI reset, Unplugged/powered off unit for 10 minutes, rebooted router,…frustrating to say the least!

Just now set router to 20/40 Mhz,  control and extension  channels to auto from 6 to see if it helps.

Going to try next adding  DHCP Reservation for the WDTV live plus

Anybody have this happen and what was your fix? Searching forum now for help.

Thanks, T


#2

Try manual network configuration on your WD TV Live instead of (or in addition to) reservation on the router. That worked for me.


#3

@THXTom

I’d guess you have too weak of a wireless signal to make things work well.  I once had the router you have for only a few days because it had a pretty weak and unusable signal .  So, I returned it for a refund.  I then turned around and bought the better model, the ASUS RT-N66U, because it had a reputation for excellent signal strength, and it does at my two-story home (both in 2.5G and 5G signals)…  The model you have has an internal antenna.  The RT-N66U model has three large individual external directional antenna.  I will never buy a router with internal antenna ever again – my earlier Linksys had external antenna, and I used to work in radar and radio electronics, so I should have known better than to get “less antenna”, in the first place.  When it pertains to antenna, SIZE (and quantity) matters!   Anyway, lesson learned for me.

,

OK, let’s see if we can help you get a better signal.  First of all, download and install the latest frimware for your router. It is easy to do for an ASUS, and important to do so.  They are constantly making improvements with it.

Next, go to www.metageek.com and download their free inSSIDer program for your kind of computer. I used this program to adjust my router for peak performance by aiming the antenna to reach the farthest distance (using a laptop to pick up the signal strength in a far off room).  The program also helps you determine which channel you should be on.  I ended up putting mine on channel 11 because it was the least crowded for me.  The best channels to be on are 1, 6, or 11 according to inSSIDer.  I also selected to be on 44 for my 5G.

Most of my router’s setting are set at the defaults except for the wireless setup. It’s really not a good idea to go tampering with too many settings other than the typical ones for basic setup.   I will attach screenshots of both my 2.4G and 5G settings.  Yours should be set the same except for the best channel you can find, and your password, of course.  I spent a lot of time researching each one of these settings (and some of the people here helped me to determine some of the “tricky” ones).  I also have the power setting at the max for my router – 200mW.

Most of our home network is wired, except for some wireless printers, and the iThings.  We had great range with our older G-router, and we wanted the same with the new one; especially on the 5G frequency, because it is the best one for streaming – but also the one with the shortest range.  Bottom line is,  we have solid coverage of 5G in every nook and cranny of the house, so streaming 1080p video works great to the iPads wherever we are in the house.

Let me know if you have questions about any of this.