WDTV live not reading WD Essential 3TB


I am having issues with getting my WDTV LIve to recognise my WD Essential 3TB external drive.

When plugged in, the drive switches on as soon as the player is switched on, but it does not appear in the list of devices on the software menu, nor does the USB light on the front of the player light up.

The drive works fine with my PC, no issues at all.

I do remember being able to use the drive without any problems about a year ago, and I have not changed anything with the hardware of the drive or the file system at all. The only thing I have done since then is move files to/from the drive.

What I did change with this particular setup is the firmware on the player. I kept the firmware updated as normal through the network update feature on the drive itself.

Any ideas on how I can fix this issue?

According to WD the devices are compatible together…



You may reset your player by holding its reset button for 4 seconds.  If this does not fix it try rolling back to the previous firmware.

Will give it a go, thanks for your reply (had no luck with WD’s email support yet).

Just something I’ve noticed in the firmware release notes, there is something about >2TB drives being blocked temporarily. Why is this? Could this be what is causing the issue?

OK, tried the reset but that hasn’t fixed the issue. Neither port will pick up the drive.

Although, I can see that none of the settings have changed in the software menu, so I’m not sure the reset actually worked?