WDTV Live Network Woes Every Time


#1

WDTV Live

Wireless USB Adapter: Linksys WUSB600N V1

Router: Netgear WNDR3300

Buffalo Linkstation NAS

Latest firmware

Any video I play, 720p or not, no matter the container or video type because I’ve tried several, ANY video, will play for about 2 minutes then stop. And it doesn’t just stop, the thing becomes unresponsive for another minute or 2. Here is the fix: go back to network setup and pick either my G or N wireless signal, whichever one it’s not on. This may or may not work then. When I go back to the share, media files may or may not be present in current folder. If so, the video will play.

However, this is incredibly annoying. Especially when I try to reconnect to the network and I sit and stare at the Working animation for however long it decides. During which time the remote does nothing. I mention above any video does this whther 720p or less. I can’t play 1080i/p at all through either network even though the unit makes that claim and I bought extra hardware just so it would be on the approved hardware list. Made no difference.

I’ve found if I can get it playing then leave the unit on, I can come back and it will play. I also notice several people have these same issues.

My girlfriend gets upset when we go to watch something and stuff like this happens. I get pissed and she thinks she bought me a bum unit as a gift. I tell her “it’s not your fault,” but whose is it? I’ve done everything according to the manual.

I’ve tried today setting up the NAS as a DLNA server, which due to how I have my file structure set up is not the best option – but it told me no media was found.

What can I do to fix this? Why doesn’t it work?

I go through a lot of computer hardware myself. In fact I am the buyer for my albeit small-sized company. My experience with this thing will definitely influence my decision to buy WD products in the future.


#2

Forgot to mention that leaving the thing powered on all the time is not an option. I’m not going to waste power and precious hours on the ??? MTBF on this thing. Don’t know what that number is but judging from how it performs I’m not very confident. I’m not going to let this gadget’s failures tell me extra steps I have to go through to get it to do what it says it can do.

It’s taken me a few minutes to write up my rant and that may be more than some think is warranted – but I’ve wasted 20X more time sitting in front of the WDTV waiting for it to work.

If I could return it I would (but even that is an unnecessary amount of work). Unfortunately I don’t have the box and it’s probably past the time limit anyway.


#3

Ok, dumb question.   As averse as it sounds you are to leaving things on 24/7, I have to ask:   Is your ROUTER / SERVER on all the time?   

If not, and you’re powering it up only when you plan on using it, make sure you give it several minutes after powering it on before you power ANYTHING up on your network.   Your PC, your WD, everything needs to wait at least 5 minutes after you turn on the router before you boot them.


#4

Yes, the router and NAS are on all the time.


#5

Latest news: Set the NAS up to be a DLNA media server, yet according to the WDTV there is no media in the current folder (I checked, there is).

Also for some reason regardless of the wireless network I’m on, I can view listings in network shares but when I try to play a video all I get is the Working animation. Which is funny cuz it’s not working lol.

What do you guys think of this: http://www.newegg.com/Product/Product.aspx?Item=N82E16815293008&cm_re=media_player-_-15-293-008-_-Product


#6

Before you give up all hope, try a last ditch solution:

   When the WD is on and fully booted, poke the reset button on the side of the box (the itty bitty one next to one of the USB ports).   That’ll reset the box.  Poke it for just a few seconds.

   If the problem remains, go to the SETUP screens and do a RESTORE FACTORY SETTINGS.   

If that doesn’t work, and you want to eiliminate some potential problems, go buy yourself a long enough ethernet cable to HARD-WIRE your WD.   It doesn’t have to be the permanent solution.   If it WORKS on WIRED, then you know the problem is related to your WLAN.

If none of those fix it, then here’s more specifics on your symptoms:

If DLNA is reporting that there’s no media in the folder, it’s because the server told the WD there was no files available.  It could be that the files are not supported by the DLNA server software.   What software is your NAS using?   And what kind of files are they?   And did you make sure you allowed the DLNA software to fully index the stream-enabled folders?

I don’t know anything about the O!Play.   But what I can warn you about:   Chances are these same network issues you’re having with the WD will persist with MANY streamers.    MOST of them are using the same underlying software to discover the network and access files, and that software is called SAMBA.   

SAMBA has been around for YEARS and YEARS, and is very reliable.  

I know it ain’t what you want to hear, but if your network is solid and stable, these problems you describe just do not happen on the WD Boxes.  I’ve been helping people troubleshoot various network issues here on the forums since the Live+ first shipped, and in the vast majority of cases, it was something wrong with something OTHER than the WD.   But to be fair, most of the things I troubleshoot with folks are sharing issues.   These phantom WLAN and connectivity problems are a whole different lot, and are difficult to troubleshoot via forums.

The WDs do have their issues, sure, and occasional network glitches are one of them, but not nearly to the magnitude you describe.

Sorry… :frowning:


#7

Charlie,

Tony is right and this forum is lucky to have his input.

Your symptoms are not characteristic of the performance of the WDTV Live.   You really need to isolate the problem, first with your NAS and WLAN before you go out and get a new box.  Not that I have stock in WD, but you most likely will have the same/similar problems with another player.

Try the wired LAN approach first, or maybe even try a video on a USB drive/stick plugged directly into the WDTV Live.  If you can’t get the file to play properly from the wired LAN or USB drive/stick (and you’re sure that it is a compliant format), then you might have a bad box (somewhat unlikely, but it happens).

Good luck.