WDTV live Media server issue


#1

All,

My WDTV Live has started behaving oddly when accessing music via the Media Server option. It holds onto folders that no longer exist on the media server itself - I had a little tidy up. Not only that but it has listing oddities within individual music folders, some will contain many more files than are there (for instance if there are 11 tracks it may say there are 51, repeating tracks etc). I have tried resting the unit in both the software and using the external reset button. No change.

If I access the music through the network share option I experience none of these problems, although playing files like this is a little unreliable, occasionally it’ll loose the music server. This NEVER happens when accessing through the Media Server option, so I would prefer to use that, but then I have the other issues above.

Can anyone suggest how to resolve the issue?


#2

The file list presented in Media Server screens is the responsibility of the SERVER, not the WDTV.  

What Media Server are you using?


#3

Ahhh, OK. That makes sense. It is a Buffalo 2T Linkstation Pro running the latest 1.33 firmware. In the Linkstation Pro web interface I have refreshed the data base and restarted the media server and even tried updating the DTCP-IP funtion. No joy.


#4

I am having problems with a similar setup. Buffalo Linkstation Pro 1 TB firmware 1.33 and WD TV Live.

Since I started noticing the problem after a firmware upgrade (1.31?). Symptoms are:

  • Changes to playlists are not correctly reflected on WDTV Live.
  • Playlists sometimes don’t make any sense at all, with random entries duplicated or starting with a song that is no longer in the playlist. I have a 204 song playlist that is currently showing 278 songs on WDTV Live.
  • m4a DRM free files from itunes will no longer play. WDTV shows them in the playlist. When the list is playing it just skips any m4a files and plays the mp3 files. m4a worked previously.

#5

Hi,

I just hit similar problems. My setting here: WD TV Live + Buffalo LinkStation Duo 1TB. Access to the storage from my player as “Media Server”  worked fine, until I updated the storage from firmware 1.24 (shipped) to 1.34 (newest).

Since the upgrade, the Media Server function does not work anymore.

Could it be, that Buffalo added a filter to deny Western Digital hardware to access this box? I didn’t manage to get this working again, and accessing via simple network mount is far from acceptable.

Frank


#6

Wow.   That’d be nasty if they did, but I doubt it.

You may need to go in there and make sure all the configuration items for Media Server settings survived the firmware upgrade.


#7

I suspect it is just a bug in the firmware. Postings on the Buffalo board are complaining of the media server not working with latest firmwares. I don’t think this is specific to WDTV Live.

I posted to a thread on the Buffalo discussion boards and suggest anyone with a problem do the same.

Buffalo Message Forum link


#8

Also, if you follow the buffalo thread in my previous post, there are several people who suggest “restore to factory defaults” on the linkstation pro. I did it twice and it did not work. Just forced me to re-enter my settings for the NAS.

Hope this saves you some time.


#9

I had a similar issue when trying to solve a network shares problem.  here’s how i resolved mine

Problem. old video kept showing up under “media server” but video was not actually there.

(windows 7, Windows Media Player 12.0.7.a bunch more numbers., WDTV Live Media)

Solution: The problem was with windows media player  “video library” being read by wdtv under “media shares.” i solved it by doing the following.  in the left hand column of WMP12 if you right click on videos, select “manage videos”, when the box opened there was a listing for the video that was long since deleted. i deleted the entry from windows media player. looked in "“media server” folder and the entry was  gone. Problem solved. Clearly wdtv live was reading the shared directory in Windows media player and that’s it. Don’t remember setting that up but i did have that set up when i was using an xbox 360 to stream video. maybe that’s why it shows up. no clue.  i don’t know if this relates to other programs but seems like it could happen with tversity or some other program that streams. But it could be just microsoft’s [deleted] way of doing stuff too. Oh you’d also probably have to click on each music, pictures, video in wmp and clear them all and readd all your media. That may help whoever said they had folders with like 50 songs and repeats when they knew there were only 15 songs. i’d suggest clearing the library then readding everything and seeing if that clears it up. kinda remindes me of itunes how it can’t tell you’ve moved a song so you can get tons of entries. So try that and see if it helps.

still can’t get my network shares working again. That is really pissing me off. [deleted] i don’t even use media shares normally


#10

[deleted] network shares just came back on. I have no clue how. this thing utterly perplexes me. Only thing i did was uninstall silverlight. but it was working with silverlight installed two days ago so go figure. And it didnt’ work immediately after i uninstalled silverlight. i wrote the above email in that time. regardless it works go figure. it will probaly break in the morning knowing my luck. the network share connection that is.