WDTV Live media catalogue not working as wanted/seen before

Hey all,

I’m new to the forums so apologies if this is in the wrong section/already been covered, I did attempt to do a quick search prior to posting this but haven’t found anything which resolves my issue.

So I’ve got the newest WDTV Live (and newest firmware) and have shared a folder on my Windows 8 PC. The Films/TV Shows I have on my PC are playing fine through the WDTV with no lag/stuttering and I can find them through a folder search on the WDTV.

When I had a HDD plugged in to the WDTV it catalogued the TV Shows and Films properly and got information for each programme from IMDB and such like sites, but now that I’ve got the share folder set up it doesn’t seem to be doing that. I have to navigate through the folders in my PC to find the desired files I want.

I just wondered if anyone knew of a workaround for this so it works how it used too. Ideally want it to work like XBMC does in the way it downloads and shows all the relevant information for the programme you are looking at and loads up images/trailors.

– Edit (Didn’t include this sorry);

-

Which firmware?

Newest - Not sure on number sorry but updated it this morning and tried again.

-

What happened?

Media Catalogue not working

-

What were you doing?

Browsing files

-

Does this happen every time?

Yes

-

What hardware and media were you using?

WD TV Live Streaming, .mkv media files

-

Did this happen with previous firmware?

Yes

-

Does power cycling the unit solve this?

No

-

Does resetting to factory defaults solve this?

No

-

Have you tried this on other devices?

No

Any & all advice would be greatly appreciated!

Beel

Have you configured the Media LIbrary Manager yet? 

TonyPh12345 wrote:

Have you configured the Media LIbrary Manager yet? 

 

 

Don’t understand what you mean?

Are you referring to activating Windows Media Share option on the device? Or is there something I’m missing somewhere?

Just a little reading will get you there…:smiley:

Setup/System/Media Library/Media Library Manager for Network Share/Add network share to media library

edit * also make sure you have selected media library in sources

from the main menu select Videos, then hit the red button on the remote, select My Media Library

1 Like

Bloodshot wrote:

Just a little reading will get you there…:smiley:

 

Setup/System/Media Library/Media Library Manager for Network Share/Add network share to media library

 

edit * also make sure you have selected media library in sources

 

from the main menu select Videos, then hit the red button on the remote, select My Media Library

If it’s as simple as that I am sorry! I do seem to be making a hash of this thing, it took me 2-3 hours just to get Windows 8.1 to share the files across to it.

I shall have a look tonight and get back to you on how I get on - Thank you for the speedy responses.

My bad, actually.  I sometimes forget how much there is to take in at the start of things.

Like anything new, t becomes pretty intuitive after a bit.

Okay I’ll admit that way was much simpler of getting my files across to the WDTV than the method I used hah!

It’s still not cataloging the TV/Films though, I still have to navigate through the folders rather than it splitting them out and organising them nicely. It also doesn’t seem to want to download movie/TV Show information from Movie/TVDB.

I’ve made sure the fetch thing is set to Auto so not sure why both aren’t working as desired unless this isn’t a feature and I’m confusing it with XBMC.

Ok, so you have your shares and folders into the Media Library Manager.

Have you set your Content Source to My Media Library (via the Red Button)?

Not getting movie content info has a lot to do with how your files are named.

XBMC is more forgiving than the WD.

What’s an example filename that is NOT being found?

Catalogue fixed (sort of) I had shared the 2nd HDD on my PC and it turns out to do the media share thing you have to share specific folders as well not just the whole HDD which has the films/tv shows. It is now showing them how I want in terms of order/folders but it’s showing episode 1, 10, 11, 2, 3 … etc. Anyway to fix that?

In terms of file names I have slight OCD when it comes to these so they are all named as follows; “Movie Name (Quality)” so as an example I have “Django Unchained (1080P)”

For TV Shows they are named as follows; “TV Show S##E## (Quality)” i.e. “The Big Bang Theory - S07E10 (720P)”

Now it has pulled the information for some of the TV/Movies but not all of them. Big Bang has worked and it has all of the info and same with Now You See Me but Django hasn’t worked and neither has Elementary.


You are correct in that a little reading will get you there.

But…

OK, here’s what I found.  Excuse if it’s a little on the detail side, but this may help the folks who haven’t yet spent hours in trying to figure it out, not to mention the countless clear, rebuild, resets that I did.

upgraded firmware from 1.16.13 to 2.01.86

did a “reset” from the reset button on the unit’s underside.

From setup>=System>=Media Library>=Media Library Manager for Network Share>=Add network share to media library

So, when I go to Videos, it would show ALL the shared folders

I select the shared folder for Movies, then it shows all the Movie folders, but without the Movie info showing, which it used to show AT THE FOLDER  LEVEL also, when in the movie’s folder, selecting option did not show the item to Get Content Info.

Side bar: each movie is in a folder.  I used thumbgen to create an xml Movieinfo export file and a jpg Thumbnail in .metathumb

I also used the “folder extension trick” to have the xml Movieinfo display in folder view.  

example, Avatar is in mkv format, the name of the folder is “Avatar (2009).mkv” I placed a copy of the xml movie info into the root level where the folder is.

Now that I’m near my point, I’ll make it.

By setting the red button on the remote, and select My Media Library

ALL of my folders are now showing the Movie info.

Also, when in a folder, with the media file, pressing the option button on the remote now show’s the Get Content Info

So the ‘trick’ is to to set content source by the red button on the remote to My Media Library.

Also, the simplest XML editor is freely available from the Microsoft Download Center, “XML Notepad 2007”

While I appreciate the amount of detail you’ve gone in to the steps you’ve mentioned have all been done, I’ve added the folders through the media share in system options. I’ve clicked the red button and the Get Content button is there when I click on Options BUT when I ask it to get content for “Django Unchained (1080P)” it’s saying that it cannot find the movie info. It’s doing the same for TV Shows as well.

TonyPh12345 mentioned that it might be to do with the way I’ve named the files but I’m not entirely sure what’s wrong with the way I’ve named my files. Also if that is the case why is it working for some and not others.

The “(1080P)” will throw it off, it’s not part of the original moviie name.  When you try to get the movie info, and it fails, notice on the right there is an option for modifying your search.  Use that, change the name to remove anything not in the original movie name and search again.

It also doesn’t like underscores, which many DVD titles use.  Sometimes narrowing the search to the minimal number of terms yeilds beter results, like “Django” instead of “Django Unchained”

Ahh okay, I guess I’ll go through and rename all of my files on my PC and just tell it to do a rescan for Content Info. That’ll be easier than going through each file one by one on the WDTV.

I’ll give this a shot tonight and let you know

Can I just say to everyone that has responded on this thread I really appreciate any/all advise that has been given so far by all of you!

Hmm, so I tested it 2 days ago (haven’t been home for the last 2-3 weeks) and all was well. Working a charm until last night/today. My device won’t even turn on now, attempted to use the reset button on the bottom as well which made no difference so I’m having to return the product via Amazon.

Main reason for the comment is that what was mentioned here worked perfectly in terms of sorting the Library out :slight_smile:

I’ve been using FileBot & TVRename to rename my files and pull the relevant information from TVDB/IMDB and since then WDTV has not had any problems getting all of the other information.