WDTV Live loses all settings and can't upgrade firmware

My WDTV Live loses all settings every time it gets switched off.

Thought this might be fixed by a firmware update but it turns out I can’t update the firmware either.  I see ‘New firmware found, do you want to upgrade’, click OK and get ‘Downloading new firmware’ but it never gets past 0%.  I’ve left it hours, doesn’t move.

Tried updating firmware from USB and it hangs after I click OK to upgrade, I have to switch the box off/on to get back in.

I can connect to the Internet from the device, watch YouTube videos fine.  I’ve reset to factory settings, done a ‘hard’ reset… no luck. 

Bit stuck. Any ideas?

Current firmware: 1.02.21
New firmware: 1.06.15_V

Thanks!

If you haven’t tried it already, some people have had luck using smaller thumb drives that are FAT32 formatted, as opposed to NTFS.

Thanks for the reply Tony.

I read a couple of threaeds suggesting that, so tried a couple of thumb drives, formatted to FAT32 - no luck. 

A new folder .wd_tv with 2 files wdtv.cas and  wdtv.cas.md5 gets created on the thumb drive but that’s it - the box just hangs.