WDTV Live Keeps Resetting

Since the most recent update, whenever I choose Youtube, Netflix or even Hulu, the machine randomly resets.

It does it most with Youtube. I choose the Youtube Leanback app, it goes to a black screen and starts loading. Sometimes it gets to the Youtube Logo, but then the machine resets.

Sometimes I’m already at the video selection for Youtube, I choose a video and instead of playing the chosen video, the WDTV Live resets again.

I’ve tried using both User Interfaces and it happens just as frequently on both.

I eventually had to pair my tablet’s Youtube app to the WDTV, run Youtube from there and tell it to play the videos on the WDTV.

This is incredibly frustrating.


Since the latest firmware upgrade (ver. 2.02.32) the same thing is happening to me when I try to run YouTube as Akhaz has described it. The machine just resets itself. I’ve tried to reset the device to factory defaults as I’ve read it in the firmware upgrade help - but the problem didn’t go away.

This is very frustrating indeed!

1 Like

Yes I have the same Issue with Youtube, the Unit is restarted when i open Youtube…Very Annoying…

Please look into this

1 Like

This is just unacceptable.

I’m sort of ok with the Youtube Leanback app sometimes logging out when the I turn off the machine, but resetting the hardware every single time I try to launch the app is just downright wrong.

What would’ve happened if I didn’t have a tablet or smartphone that could pair with the WDTV Live and connect to Youtube to launch the app? There would be no way to launch it without having the machine reset.

This isn’t just one step forward and two steps back, this is half a step forward (since they fixed the back button for the app) and five to ten steps back.

This has to be fixed as soon as possible, without having to wait months for a new firmware.

I have rollback to the old firmware due to this issue


This kept going five more times after I stopped recording. In the end, I gave up and and hooked my laptop to the TV.

I had the same problem as i was getting no help so had to roll back to the old firmware. 

malik43 wrote:

I had the same problem as i was getting no help so had to roll back to the old firmware. 

Did that work?

Yes, I have no issues playing Youtube on the old firmware but i really wish if they could fix the issue with the new firmware, i am not sure if this feedback is been taken into consideration.