WDTV Live Hub won't turn on despite being accessible through the network

I can access my files through my computer but I can not actually turn the device on to use with my TV. Is this a known issue? I am using the latest firmware at the time of writing.

No, it’s not a known issue.   There are issues with hubs that won’t even power on at all (as in, not even on the network) but not that won’t come out of standby.

My guess is that you actually have an issue with the video connection or configuration.

How is your Hub connected to your TV?

Have you tried the other cable methods such as Component / Composite ?

I am using an HDMI connection to my receiver, which routes to the TV. I have not tried using composite or component and I would not want to even if it worked; I want HDMI.

So my unit is on standby? That makes sense.

Fault find… is the Hub or the AV Reciever ?

Isolate the problem …

Switch off your AV Reciever and Connect the Hub Directly to your TV via HDMI … Does the problem still happen ?

Yes … Then there is a potential problem with your Device

No …  Then it’s somthing to do with the AV Reciever (More than likely HDMI Control/Power  Settings… Consult the Manual)

SIDE NOTE:  A friend of mine has a ‘Top of the Range’  AV Reciever and he couldnt get it working with his WD Live SMP … he left all the dozens of settings on ‘AUTO’ … after messing about for about an hour and ‘MANUALLY’ inputing settings into the AV Reciever … finally got it working.

Call me stupid or call me smart, but here’s what *I* would do:

Connect the hub directly to the TV for the time being

Place the TV on the proper input HDMI, composite

Press the Power button on the Hub

  Do you see the hub’s white WD light on the front of the hub start flashing and then go solid and NOTHING on the TV?

    No - then try using the RED Power button on the remote Did that work?

      No - MAY be a bad unit if the light never comes on solid

Light comes on, flashes, then goes solid but nothing on TV

 Make sure you have the TV on the proper input

  Yes it is - Then change to different outputs on the Hub and change the TV to it

    Eaxmple:  If the Hub is connected HDMI then connect composite and switch TV to composite or visa versa

        If you see a picture now go to settings and change video output to what you want it to be then change your
        TV to those settings and see if it’s still working.

         NO - Unit might be stuck in PAL mode and you want NTSC or visa versa:

                 Press reset button on bottom of Hub and hold 10 seconds to toggle between NTSC

                 and PAL. Use a fine-tipped stylus or the unfolded end of a paperclip to press the reset switch.

                 This will not cause a loss of any data on the hard drive.

After this if it’s still not working - try placing the hub in a brown paper bag with 5 pounds of flour, shaking it over your head 3 times while singing She’ll Be Commin’ Round The Mountain and then play banjo music to it for an hour. You may as well have some use of it. :slight_smile:


For real - I hope you get it working. I know how much I dislike getting home with something that’s DOA and have to take it back. It’s a pain.