WDTV Live Hub Not Receiving IP Address From Router


***FIRMWARE: 3.03.13***

As the topic says, my WDTV is not receiving an IP address from my router. However;

  • The router (D-Link DIR 615) shows in the log that it is sending DHCP offers to the device.

  • The cable functions properly, (I am posting this from my laptop connected through the cable)

  • The device does display in my Network list (Windows 7), but is not accessible.

  • The WDTV Hub MC did work for 2 days prior to this after purchase, suddenly has stopped working.

But no matter what I do, automatic or manual, it will not connect.

Automatic connection yields an error IP.

Which is obviously wrong. Manual I will set it up ( is gateway):




DNS: (have also tried and

None of these will pass the connection test. I’m running out of ideas on what to do.

Did you tried something simple like resetting the router?

Yes I have tried resetting the router.

Here is what I know:

Scenario A) WDTV is connected in its intended room, network cable does not work. While the cable is connected, the router is sending DHCP requests, none are acknowledged at any point by the device.

However, if I connect the cable to another device, such as my laptop, the connection is immediately valid and connects.

Scenario B) WDTV is connected through another cable, in this case the one in my bedroom. It functions and connects to the network immediately.

So my gut tells me the cable is defective, however I am able to use it with other devices, indicating the WDTV is defective… But I can use another cable and it works.

This is a really strange case :stuck_out_tongue:, the fact that you can connect the laptop in the intended room using the same cable and get internet, and the fact that you can connect the WDTV to the same router but from your bedroom has me confused. I think is better for you to contact tech support or maybe some of the other user have had a similar problem.

I’m having the EXACT same problem with the same equipment (DIR-615).

If you manually set up an IP address, are you able to connect to other devices, but not to the internet? I get a DNS error when I try this.

I’m interested in your scenario B. Are you still connecting to the 615? Or are you on another device?