WDTV Live Hub - MyBook Live not showing in Media Library

Hey guys,

I currently own a  WDTV Live Hub  and a  MyBook Live. Recently the MyBook Live storage has been completely filled and I bought a new MyBook Live as an add on. I’ve connected the new MyBook Live like I did for the previous one but I had some complications with the name. I however managed to change the name. After doing so, I have had problems accessing to the old MyBook Live through the Media Library. I have tried deleting it through  Setup>System>Media Library>Media Library for Network Share and putting it in again. However, I’m still not able to access it through Media Library. I am able to access it through Network Share though. To be honest, I’m not much of a technical guy. Anyone can help or give some advice on how do I solve this? 

Hi, have you tried disconnecting the new my book to see if you can access the old one?


Thanks for the response. Well, I have tried disconnecting the new my book live. But it hasn’t worked. I’ve also tried restarting the WDTV Live Hub and rebooting the old My Book Live but so far nothing is working. Any other suggestions?